ISPConfig & SSH

Discussion in 'Installation/Configuration' started by FFEMTcJ, Mar 3, 2008.

  1. FFEMTcJ

    FFEMTcJ New Member

    I got almost everything up and running perfectly.. I check shell access, but I don't get shell access for all the accounts.. How do I set this up? I think I need to add something to my /etc/ssh/sshd_config, but I don't know what.. Each user seems to have their own group instead of putting them all into one group. And when it does work correctly, each user can only see their folders correct?

    Please explain things detailed because I'm very new to all of this..

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please enable the shell access checkbox in the settings of the website and the settings of the user.

    No, only if you recompiled your SSH daemon to support chrooting and the enabled chrooting in ISPConfig in /home/admispconfig/ispconfig/lib/
  3. darkangel

    darkangel New Member

    I can't see a "shell access" checkbox ... where exactly is it?

    Using ISPConfig Version:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This thread is about ISPConfig 2 (it is in the ispconfig 2 forum). ISPConfig 2 and 3 are completely different software packages, so nothing posted in the ispconfig 2 forum applies to ispconfig 3.

    If you have a question about ispconfig 3, please post in the ispconfig 3 forum.
  5. darkangel

    darkangel New Member

    Sorry, I only noticed it was in the ISPConfig 2 forum after posting my reply.

Share This Page