ISPconfig ssh chrooted on SLES 10

Discussion in 'HOWTO-Related Questions' started by javerleo, Jul 9, 2008.

  1. javerleo

    javerleo New Member

    I was forced to use SLES 10 on my server, because the SAS controller driver is supported only on that platform. Now I have a working installation of ISPconfig but I would like to have chrooted ssh access for users. I tried to follow the path suggested on the tutorial for Debian but configure script fails:
    "PAM headers not found"
    Any suggestions?

    Thanks in advance

    :(
     
  2. falko

    falko Super Moderator

    Is there a package called pam-devel or pam-headers or similar? If so, install it with YaST.
     
  3. javerleo

    javerleo New Member

    Nop, unfortunately there is nothing like that.
     
  4. javerleo

    javerleo New Member

    A mess after compiling ssh chrooted

    I downloaded and compiled PAM then tried to compile openssh-4.2p1-chroot again...success! Then I rebooted the server to check the chroot functionality but I can't login! After typing the user name on system console I get an error message. Putty exits after typing the user name.

    Is it a lost cause?
     
  5. falko

    falko Super Moderator

    Any errors in the logs?
     

Share This Page