ISPconfig shows other site or invalid cert

Discussion in 'Installation/Configuration' started by pkaresz11, Feb 4, 2019.

  1. pkaresz11

    pkaresz11 Member

  2. pkaresz11

    pkaresz11 Member

    SOLVED!
    When in the ISPconfig panel/Websites/domain.ltp IP is the default "*", the redirection doesn't work the redirection to the correct site. You must set it to the server IP in the dropdown menu.
    :D:D:D:D
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Actually, * and IP are both fine, but you can not mix * and IP on an apache or nginx server in vhosts as an IP is a stronger match then a wildcard. So either use * for all sites or use the IP for all sites.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    It would probably be good to add a server config setting to specify whether ip addresses or wildcard is in use, or allow selectable behaviour like now (eg. if some ips are used for ssl and wildcard for non-ssl).
     
  5. pkaresz11

    pkaresz11 Member

    Thanks,Till!
     
  6. pkaresz11

    pkaresz11 Member

    And what if the customer sets himself up?can i fix this setting?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can configure under System > server config and System > server Ip what the customer is allowed to select in the IPv4 field. Allow him to justs elect * or the Ipv4 address so he is not able to select a wrong value.
     

Share This Page