ISPConfig shows FTP service offline , yet FTP working fine

Discussion in 'HOWTO-Related Questions' started by Bashewa, Feb 27, 2018.

  1. Bashewa

    Bashewa Member

    Possible bug on The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1

    From ISPConfig panel show services

    Web-Server: Online
    FTP-Server: Offline
    SMTP-Server: Online
    POP3-Server: Online
    IMAP-Server: Online
    mySQL-Server: Online

    From command line:
    # service pure-ftpd-mysql status
    ● pure-ftpd-mysql.service
    Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated; vendor preset: enabled)
    Active: active (exited) since Mon 2018-02-26 11:34:06 SAST; 1 day 1h ago
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that your FTP daemon is listening on port 21 localhost. Otherwise, its listed as offline.
     
  3. Bashewa

    Bashewa Member

    Thanks Till, does it not install to port 21 as default , I only followed tutorial and have not modified pure-ftpd in anyway , is this the correct command to check whats on port 21 ?
    netstat -tnulp | grep 21
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 1219/master
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 1219/master
    tcp 0 0 127.0.0.1:10027 0.0.0.0:* LISTEN 1219/master
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 1219/master
    tcp 0 0 127.0.0.1:11211 0.0.0.0:* LISTEN 897/memcached
    tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 1219/master
    tcp6 0 0 :::25 :::* LISTEN 1219/master
    tcp6 0 0 :::587 :::* LISTEN 1219/master
    tcp6 0 0 :::465 :::* LISTEN 1219/master
    udp 0 0 127.0.0.1:11211 0.0.0.0:* 897/memcached
     
  4. Bashewa

    Bashewa Member

    service pure-ftpd-mysql status
    ● pure-ftpd-mysql.service
    Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated; vendor preset: enabled)
    Active: active (exited) since Tue 2018-02-27 13:43:38 SAST; 2 days ago
    Docs: man:systemd-sysv-generator(8)
    Process: 32022 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0/SUCCESS)
    Process: 32034 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
    CGroup: /system.slice/pure-ftpd-mysql.service

    Feb 27 13:43:38 server1 systemd[1]: Starting pure-ftpd-mysql.service...
    Feb 27 13:43:38 server1 pure-ftpd-mysql[32034]: Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -8 UTF-8 -Y 1 -D -J HIGH -O clf:/var/log/pure-ftpd/transfer.log -A -E -
    Feb 27 13:43:38 server1 systemd[1]: Started pure-ftpd-mysql.service.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorials install it on port 21 by default, here the result of the command from a Debian 9 server:

    [email protected]:/home/administrator# netstat -tnulp | grep 21
    tcp 0 0 127.0.0.1:11211 0.0.0.0:* LISTEN 466/memcached
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 1050/pure-ftpd (SER
    tcp6 0 0 :::21 :::* LISTEN 1050/pure-ftpd (SER
    udp 0 0 127.0.0.1:11211 0.0.0.0:* 466/memcached


    as you can see, ftp is listening on port 21 on my server.
     
  6. Bashewa

    Bashewa Member

    Re-installed all fine , thank you Till , think I missed adding sql-mode="NO_ENGINE_SUBSTITUTION" to /etc/mysql/mariadb.conf.d/50-server.cnf
     

Share This Page