ISPConfig server starting stops Samba?

Discussion in 'Server Operation' started by StevenD, Jan 1, 2010.

  1. StevenD

    StevenD Member

    Hi All,

    Happy new year to all.

    I have a problem with my setup?
    I have setup Samba to allow access to files and printers from my windows laptop. All is fine I can connect to the server through network connections on windows 7, and can see and access the shares. I can also send stuff to my printers.

    But as soon as I start the ispconfig server, I no longer have access to the server. I can still see the server in the network, but when I try to open to see the shares I get the message "The network path was not found". I then have to reboot the server, I can then reconnect but as soon as I start the ispconfig up it stops again.

    Has anyone else come across this before? I have tried searching for this problem but didn't find anything.

    Below is the contents of my smb.conf

    	netbios name = UPSTAIRS
    	server string = Upstairs Server
    	obey pam restrictions = Yes
    	passdb backend = tdbsam
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
    	syslog = 0
    	log file = /var/log/samba/log.%m
    	max log size = 1000
    	printcap name = cups
    	preferred master = No
    	domain master = No
    	dns proxy = No
    	wins support = Yes
    	panic action = /usr/share/samba/panic-action %d
    	invalid users = root
    	printer admin = @ntadmin
    	printing = cups
    	print command = 
    	lpq command = %p
    	lprm command = 
    	comment = Users profiles
    	path = /home/samba/profiles
    	valid users = %S
    	create mask = 0600
    	directory mask = 0700
    	browseable = No
    	comment = All Printers
    	path = /var/spool/samba
    	create mask = 0700
    	guest ok = Yes
    	printable = Yes
    	browseable = No
    	comment = Printer Drivers
    	path = /var/lib/samba/printers
    	write list = root, @ntadmin
    	guest ok = Yes
    	path = /mnt/windows
    	read only = No
    	guest ok = Yes
    	comment = samba
    	path = /home/
    	read only = No
    	guest ok = Yes

  2. StevenD

    StevenD Member

    Hi All,

    A bit more info.

    I turned off the firewall in ISPConfig, it now allows access to the shares again. Is there a way to configure the ISPConfig firewall to allow access to the Samba shares? Does it block the ports required by Samba?


  3. falko

    falko Super Moderator ISPConfig Developer

    Please open the ports 137 - 139 (TCP and UDP).
  4. StevenD

    StevenD Member

    Thanks Falko.

    All working fine now.

Share This Page