ISPConfig/Server not resolving sies or names

Discussion in 'HOWTO-Related Questions' started by Houdini0001, May 8, 2010.

  1. Houdini0001

    Houdini0001 New Member

    Greetings,
    I am very new to this altho I have learned alot sence I have installed CentOS 4.8 about 7 times now using the Perfect Server Setup (awsome tutorial BTW)
    I was trying to host 2 DNS's on one machine, I could not get it to work, I was using an old system p2-300mhz so I finally broke down and setup a p4 2ghz system 1gb ram and I still can not get it to work, Its probly me, but I dunno what I'm doing wrong, I even followed the how to setup a DNS at godaddy tutorial, so heres what I'v done:

    registered the following at godaddy:
    dbldogdareya.net dbldogdareya.com dbldogdareya.info dbldogdareya.us
    roziesplace.com roziesplace.net roziesplace.info

    I setup the NS1 and NS2 for Dbldogdareya.NET both point to IP: 71.20.251.92
    (its been almost 2weeks so they are resolved)( I only have 1 IP Address)
    (you should also know that my isp blocks port 80) (read further kk)

    I set roziesplace.com and dbldogdareya.com's name servers to ns1 and ns2.dbldogdareya.net

    I installed CENTOS 5.4 usng the "Perfect Setup Centos 5.3" Everything went great most everything was already installed and no problems.
    manually edited DHCP to 192.168.15.4 NS1.DBLDOGDAREYA.NET

    I downloaded ISPConfig2 to the /tmp used tar -???? ISPCo yada yada it unzipped to install_ispconfig,

    I then did ./setup ran through the screens no errors seen - did exactly what it said in the setup
    mysql server = localhost - root etc... everything is great

    system is installed, I log into 192.168.15.4:81
    change the password, change all the email address's.
    did an update for email and phpmyadmin in the update area they installed ok
    now system is up and working.. if I go to www.dbldogdareya.net it goes to the apache2 test page i'v only setup dns records for roziesplace.com
    and dbldogdareya.com with A's of www and mail and an MX record of (blank top line bottom line mail.roziesplace.com)
    when I try to go to roziesplace it times out same with dbldogdareya.com
    I'v even gone to godaddy and forwarded to 71.20.251.92:8080 both
    and nothing, httpd shows listen on 8080 router dmz set for 192.168.15.4 and I have also forwarded ports 80, 8080, 53, 81 110 etc..

    I'm just so new I have looked at diffrent files and followed all the directions setting up the server I'v installed CENTOS 5.4 2 times now, i just dont know what else to do..

    I would be greatly appricative of any assistance. If you need the root password and ISPConfig password or even want to look at the godaddy seetup I'm all game nuttin to lose now.. please email me directly houdini0001 (at) gmail. com

    THANKS BUNCHES!!
    Houdini
     
  2. Houdini0001

    Houdini0001 New Member

    netstat report
    [[email protected] install_ispconfig]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:865 *:* LISTEN 1955/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 6355/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1923/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 1818/ispconfig_http
    tcp 0 0 ns1.dbldogdareya.net:domain *:* LISTEN 6800/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 6800/named
    tcp 0 0 *:ftp *:* LISTEN 4267/proftpd: (acce
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 4779/cupsd
    tcp 0 0 *:smtp *:* LISTEN 7530/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 6800/named
    tcp 0 0 *:imaps *:* LISTEN 27503/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 27503/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 27503/dovecot
    tcp 0 0 *:imap *:* LISTEN 27503/dovecot
    tcp 0 0 *:webcache *:* LISTEN 1844/httpd
    tcp 0 0 *:ssh *:* LISTEN 4832/sshd
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 6800/named
    tcp 0 0 *:https *:* LISTEN 1844/httpd
    [[email protected] install_ispconfig]#
     
  3. Houdini0001

    Houdini0001 New Member

    [[email protected] install_ispconfig]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:40:CA:B5:5A:4E
    inet addr:192.168.15.4 Bcast:192.168.15.255 Mask:255.255.255.0
    inet6 addr: fe80::240:caff:feb5:5a4e/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:388552 errors:0 dropped:0 overruns:0 frame:0
    TX packets:224601 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:524637663 (500.3 MiB) TX bytes:19231017 (18.3 MiB)
    Interrupt:11 Base address:0x4000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2548 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2548 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2726253 (2.5 MiB) TX bytes:2726253 (2.5 MiB)
     
  4. Houdini0001

    Houdini0001 New Member

    ok hope the netstat and ifconfig help.. its another 5am and i'm pooped..
    thanks again for your time..
    Houdini
     
  5. Houdini0001

    Houdini0001 New Member

    good afternoon, just wanted to add another little note I oticed a problem this morning
    looking under services in ISPConfig it says:
    Web-Server: Offline

    I'm still able to see the apache test page by going to www.dbldogdareya.net even ns1.dbldogdareya.net and even http://71.20.251.92:8080 outside my network?
    OMG I'm so freaking lost - I dont mind the hair pulling I get mostly grey hairs anyway hehehehe ..


    PLEASE If anyone knows what the heck I've done wrong I'd be ever so greatful, even guesses wouldnt hurt. Smile... help a guy out... hehehe

    thanks everyone..
    Bob
    aka Houdini

    Pssst i'm going backwards in the thread i'm down to page 165 but still hopeful I might find someone that has had this probly easy to fix dumb deer in the headlight look on ur face problem.. I'm on a path to Linux enlightenment, me thinks... hehehe
     
  6. Houdini0001

    Houdini0001 New Member

    well ok update -
    I came across this post about a file called Vhosts_ispconfig.conf
    well all said and done it had IP 192.168.15.4 port 80
    Sooo I changed the port 80 to 8081 for dbldogdareya.com
    and port 8082 for roziesplace.com and went to godaddy and forwarded with
    masking to those ports - SO FAR SO GOOD! I have not tried email yet but
    we will see, its a fix for now, hopefully someone will have another solution.
    hasta for now,
    Houdini
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Code:
    mh1:~# dig www.dbldogdareya.net
    
    ; <<>> DiG 9.3.4 <<>> www.dbldogdareya.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21565
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.dbldogdareya.net.          IN      A
    
    ;; ANSWER SECTION:
    www.dbldogdareya.net.   3600    IN      CNAME   dbldogdareya.net.
    dbldogdareya.net.       3600    IN      A       [COLOR="Red"]64.202.189.170[/COLOR]
    
    ;; Query time: 119 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Sun May  9 17:03:27 2010
    ;; MSG SIZE  rcvd: 68
    
    mh1:~#
    Is 64.202.189.170 your server's public IP?
     
  8. Houdini0001

    Houdini0001 New Member

    no,
    all I did was create A's ns1 and ns2 and pointed them to my IP address, I followed the godaddy DNS setup that howtoforge had a tutorial for, only problem is I cant use port 80 My ISP has blocked it and when I try to add the port in with the ip address godaddy sytem says invalid IP. Heres the godaddy info:

    Total DNS: (Available)
    ARecord ns1 71.20.251.92 <--- this is my IP
    ARecord ns2 71.20.251.92
    ARecord @ 64.202.189.170 <---- this is godaddys
    CNAME www @
    CNAME mobilemail mobilemail-v01.prod.mesa1.secureserver.net
    CNAME pda mobilemail-v01.prod.mesa1.secureserver.net
    MX @ smtp.secureserver.net
    MX @ mailstore1.secureserver.net

    Forwarding: On (Last Update 5/1/2010)
    Forward with Masking
    http://71.20.251.92:8080

    Host Summary (add)
    NS1 delete edit
    NS2 delete edit

    1 to 2 of 2
    (Here is what happens when I try to add the port)
    Zone File Record Status
    ARECORD ns1 ERROR - 71.20.251.92:8080 is not a valid IP address

    BTW Falko - Thanks a tun for your help, I really do appricate it!
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Change
    Code:
    ARecord @ 64.202.189.170
    to
    Code:
    ARecord @ 71.20.251.92
    and disable the Forwarding option.
     
  10. Houdini0001

    Houdini0001 New Member

    still no go.. ISP wont allow port 80, I even tryed to set the router WAN 80 to translate to 8080 but no go. so I changed the Arecord back and put forwarding back.
    I dunno what else to do other then change ISPs cause its causng problems we have had to add the IP with the port to some of the files for things to work.

    thanks for the help
     
  11. falko

    falko Super Moderator ISPConfig Developer

    The problem is that virtual hosts don't work with DNS forwarding. You need to set the DNS records directly to your public IP. This has nothing to do with the ports you use. You can use port 8080 and make your router forward it to port 80 internally.
     

Share This Page