ISPConfig + Roundcube - We need a vacation plugin

Discussion in 'Tips/Tricks/Mods' started by Steve85, May 25, 2013.

  1. Steve85

    Steve85 New Member

  2. Horfic

    Horfic Member

  3. Steve85

    Steve85 New Member

    Oh great.

    I tried to install but if i add the "roundcube.conf" to my apache2 folder and i want to restart the apache i get this error:

    "httpd start: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 59 of /etc/httpd/conf.d/roundcube.conf: Expected </link> but saw </head>"

    I dont see line 59? xD Any idea?
  4. Horfic

    Horfic Member

    well you don't need the roundcube.conf for the plugins to work, that is only if you want to have /webmail available at your domains.

    depends what platform you are on and what webserver you are exactly using.

    what are you doing in httpd.conf in line 221
  5. Steve85

    Steve85 New Member

    Ok - i try to get it active (actual working on https) ;-)

    The line loads your config:

    # Load config files from the config directory "/etc/httpd/conf.d".
    Include conf.d/*.conf
  6. Horfic

    Horfic Member

    you are loading from




    isn't this getting you a loop?
  7. Steve85

    Steve85 New Member

    I´m loading from:

    Confd is located:
  8. Steve85

    Steve85 New Member

    If i access over http it is all fine but i get this error:"Soap Error: fetching http headers"

    So i try to get it working over https but if i access the website over https (

    I get forwarded to "" and there comes the error "Site not found".

    Maybe i need the "roundcube.conf" that it works well?

    Any idea?
  9. Horfic

    Horfic Member

    you didn't read the docs...

    Q: I get an error "Soap Error: fetching http headers"
    A: This happens when the plugins are trying to reach your interface under http but you have it run it under https. So just change it in the config file.

    PS: Roundcube conf simply adds the alias /webmail to apache...
  10. Steve85

    Steve85 New Member

    Hm of course...

    I changed the value to:
    "$rcmail_config['force_https'] = true;"

    I get now the error in my browser = "ssl_error_rx_record_too_long".

    I use a self signed certificate? Maybe is this a problem?
  11. Horfic

    Horfic Member


    $rcmail_config['force_https'] = true;

    this option forces roundcube to be only accessible per https!

    In the configfile of the "ispconfig3_account" (/plugins/ispconfig3_account/config/ fill in your details:
    $rcmail_config['remote_soap_user'] = '{REMOTE USERNAME}';
    $rcmail_config['remote_soap_pass'] = '{REMOTE PASSWORD}';
    $rcmail_config['soap_url'] = 'http://{YOUR SERVER}:8080/remote/';
    Change the port (set to "8080" by default) if necessary and please note that when using SSL to access ISPconfig panel, use "https://" instead of "http://".
    What does it say? if your ispconfig panel is accessible per https, then you have to use https in soap url....
  12. Steve85

    Steve85 New Member

    Thank you very much!

    My first problem was that the SSL certificate wasn`t correct or better i don`t had a dedicated IP address.

    Now i have a dedicated IP address and i changed in the account mod the http to https and now it seems to work.

    Thank you very much! :)

Share This Page