ISPConfig Roundcube Out of Office Reply / Vacation Message - Error 550: Empty envelope Sender

Discussion in 'Plugins/Modules/Addons' started by pssadm, Jan 3, 2021.

  1. pssadm

    pssadm New Member

    Hi all, wondering if anyone else has or had this issue. Can't seem to find much on how one would solve this.
    I recently installed the ispconfig plugins for RoundCube. (set them up easily enough). I sent a test message to the email address with the enabled out of office reply. The server sent a message back, however, it stops short of getting all the way to the original sender. The mail server blocks the return reply with the notice below:

    to=<[email protected]>, relay=spamfilter.email.com[88.88.88.88]:587, delay=1.6, delays=0.28/0.02/1.3/0.07, dsn=5.0.0, status=bounced (host spamfilter.email.com[88.88.88.88] said: 550 Empty envelope senders not allowed (in reply to DATA command))
    Jan 2 21:17:09 ns1 postfix/qmgr[28010]: DA3B868C0795: removed


    I can only assume that Roundcube is not attaching a sender email address when responding with the notice.
    Does anyone know what I can do to make Roundcube include that information in the return reply?

    Thank you so much in advance!
    Best regards, and happy new years everyone!!
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Which ISPConfig version are you using? Did you follow a guide to set up the plugins and if so, which? Can you share how exactly you set up the reply?
     
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Empty envelope senders are used all the time, and even required for proper function in some places; sounds like the receiving server is poorly configured.

    If you want to work around this problem on the remote server, I think you can change what dovecot uses for the sender in vacation replies. (Fwiw, I would probably just report the brokenness to the other side and let them fix it.) Roundcube has nothing to do with the actual reply, it is just a ui to configure what is ultimately a sieve script.
     
  4. pssadm

    pssadm New Member

    Thanks Th0m for your response, I used these instructions for Debian, though i am using Ubuntu 18.04.5 LTS (Bionic Beaver)) with ISPConfig 3.1dev

    https://www.howtoforge.com/tutorial/ispconfig-3-roundcube-plugins-on-debian-stretch/
    I setup the Autoreply with the few fields that are available. Set date start and end.. and save it.
     
  5. pssadm

    pssadm New Member

    Thanks for your response Norel, the receiving side is using Barracuda spamfilter and is set to not receive messages without the sender email included within the envelope. It's probably a good thing from the receiving side not to allow such messages in order to reduce the amount of spam and malware. That said, I think the sending side should have the ability to include this when replying with the "out of office" message... no?
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    RFC 5321 requires some messages to be sent with a null sender; if they outright block all null sender messages, they are violating the rules by which mail systems agree to send mail. How is that a good thing? The very fact that you have posted this thread, working through this issue and have brought in the help of numerous unaffiliated third parties to try to find a solution to work around a system that is violating the normal mail delivery rules would seem clear evidence it is not.

    Your system does have that ability, as I mentioned above. A quick search for that would find eg. https://wiki2.dovecot.org/Pigeonhole/Sieve/Extensions/Vacation which describes the options.
     
    pssadm likes this.
  7. pssadm

    pssadm New Member

    I'm not familiar with the RFC's. I just assumed that there would be an option to enable the sender in the response, I just couldn't find it, that is the reason for my post.

    This is exactly what I needed to get around the existing issue!! I will research the RFC to see that I don't break anything.
    Thank you so much Jesse!!
     
    Last edited: Jan 5, 2021

Share This Page