ISPConfig reporting PureFTP

Discussion in 'Installation/Configuration' started by N3RVE, Jun 17, 2014.

  1. N3RVE

    N3RVE New Member

    I just setup a VPS with Ubuntu 12.04 server at Linode using this guide. ISPconfig is reporting FTP being down and I can confirm it is down as FTP connections are refused.

    During setup, after remounting with the updated values in the fstab file, running these
    Code:
    quotacheck -avugm
    &
    Code:
    quotaon -avug
    commands generate errors.

    Code:
    [email protected]:~# quotacheck -avugm
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    Code:
    Last login: Tue Jun 17 18:43:29 2014 from 41.203.67.141
    [email protected]:~# quotaon -avug
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    [email protected]:~#
    There's no output for
    Code:
    netstat -tap | grep ftp
    .

    Code:
    [email protected]:~# ps -aux | grep ftp
    Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    root      5133  0.0  0.0  12784   748 ?        Ss   18:02   0:00 /usr/lib/openss
    h/sftp-server
    root      5379  0.0  0.0   9392   928 pts/0    S+   18:10   0:00 grep --color=au
    to ftp
    Code:
    I just setup a VPS with Ubuntu 12.04 server at Linode using [URL="http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p5"]this guide[/URL]. ISPconfig is reporting FTP being down and I can confirm it is down as FTP connections are refused. 
    
    During setup, after remounting with the updated values in the fstab file, running these [code]quotacheck -avugm
    &
    Code:
    quotaon -avug
    commands generate errors.

    Code:
    [email protected]:~# quotacheck -avugm
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    Code:
    [email protected]:~# quotan -avug
    No command 'quotan' found, did you mean:
     Command 'quotaon' from package 'quota' (main)
     Command 'quota' from package 'quota' (main)
    quotan: command not found
    There's no output for
    Code:
    netstat -tap | grep ftp
    .

    Code:
    [email protected]:~# ps -aux | grep ftp
    Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
    root      5133  0.0  0.0  12784   748 ?        Ss   18:02   0:00 /usr/lib/openss
    h/sftp-server
    root      5379  0.0  0.0   9392   928 pts/0    S+   18:10   0:00 grep --color=au
    to ftp
    No output for
    Code:
    cat /proc/user_beancounters
    Any help is appreciated
     
    Last edited: Jun 17, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Please check the command it must be


    Restart the service for ftp
    if it is not there then reinstall it
     
  3. N3RVE

    N3RVE New Member

    Correct output for quotaon -avug:

    Code:
    [email protected]:/tmp# quotaon -avug
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    [email protected]:/tmp#
    No output for these commands:
    Code:
    [email protected]:/tmp# /etc/init.d/pure-ftpd-mysql restart
    [email protected]:/tmp# netstat -tap | grep ftp
    [email protected]:/tmp
     
  4. N3RVE

    N3RVE New Member

    After spending several hours looking for the problem, I found that it was related to the certificate that I created at /etc/ssl/private (pure-ftpd.pem) following the guide.
    Code:
    echo 0 > /etc/pure-ftpd/conf/TLS
    Running that stops PureFTPd from checking for the certificate during start-up.
    Code:
    service pure-ftpd restart
    Code:
    service --status-all
    I ran the status check and there was a [+] before pure-ftpd.

    My only issue now is that I get authentication failures for FTP accounts that I've just created. Any ideas?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    are you sure that you use the correct username (incl. prefix) as shown in the ftp user list?
     
  6. N3RVE

    N3RVE New Member

    Thank you for your reply.

    Yes, the username along with their passwords are entered correctly.
    I always remove prefixes for ISPConfig installations.

    Update: I've also noticed that after adding an FTP user, I don't get the notification about waiting for a minute for changes to take effect. I just get returned to the FTP users list with the new user added.
     
    Last edited: Jun 19, 2014
  7. N3RVE

    N3RVE New Member

    I've resolved this issue. I followed the guide carefully, but somehow pure-ftpd-mysql wasn't installed. This helped :)
     

Share This Page