ISPConfig remoting plugin

Discussion in 'General' started by till, Apr 26, 2007.

  1. till

    till Super Moderator

  2. 3cwired_com

    3cwired_com New Member

    I think I have read every thread about the remoting plugin before i decided to post, it is not working for me, I even updated to the latest version of ispconfig, and disabled the xml statements as per the instructions. The only thing I do end up getting is

    "Script end..."

    I installed the package and added remote users, and I still get no response.

    this is the response from me running this script:
    http://www.domain.com:81/remote/index.php

    output:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.


    <SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

    <SOAP-ENV:Body>

    <SOAP-ENV:Fault>
    <faultcode>Server</faultcode>
    <faultactor>method '' not defined in service ''</faultactor>
    <faultstring/>

    <detail>
    <soapVal xsi:type="xsd:string"/>
    </detail>
    </SOAP-ENV:Fault>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
    +
    <!--

    soap_server: entering parseRequest() on 08:34 2007-07-31
    soap_server: Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
    soap_server: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    soap_server: Accept-Encoding: gzip,deflate
    soap_server: Accept-Language: en-us,en;q=0.5
    soap_server: Connection: keep-alive
    soap_server: Cookie: SMFCookie468=a%3A4%3A%7Bi%3A0%3Bs%3A1%3A%221%22%3Bi%3A1%3Bs%3A40%3A%221fd0f18e5783e1b10cf23e431743f3556a383b99%22%3Bi%3A2%3Bi%3A1368529334%3Bi%3A3%3Bi%3A0%3B%7D; cookie_test=please_accept_for_session; HESK=39103c739531c0a3de2004a6518e02ed; sessionispconfig=e233e57b127059cca0899313de314016; a65f03b910d2a93c4082717d7d283407=700c49bfe06993f89c5fd27c94b83ae6; 4d4c585e3d720eae71ecacffc4c94eeb=78c38327cfb2b34176ebde0774185163; 33ea1bf6d476f0fc654735a0b6317d48=b73abbba40114a62934e0d486ba4cfdf; ea09bb364ef1bffd889e76b7a59035fc=c54c66978c931f6de9ec4a5c040809ba; IRMSESSID=d2b39a08229db8ebc7232f51a912c0c0; eZSESSID3cadmin=1acac22cbe38357d4a901726b7f7e01a; eZSESSID=2e9fbd8c6b03305eccc3b8783c5e70fb; PHPSESSID=e172c710f3b1c5b1526e6d7afb509953; ezcst_unfolded_node_list=n2%2Cn164%2Cn118%2Cn131%2Cn43%2Cn59%2Cn122%2Cn138%2Cn101%2Cn206%2Cn77; zenAdminID=ad90af0a18a2450db3d53f3e6e3b83fd; zenid=40dd776ae8a3971a5ee6c155797bcefe
    soap_server: Host: www.domain.com:81
    soap_server: Keep-Alive: 300
    soap_server: User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
    soap_server: got encoding: UTF-8
    soap_server: method name:
    soap_server: method '' not found!
    soap_server: parser debug:
    soap_parser: xml was empty, didn't parse!

    soap_server: server sending...

    -->
     
    Last edited: Jul 31, 2007
  3. till

    till Super Moderator

    Please post the script that you used, comments stripped.
     
  4. 3cwired_com

    3cwired_com New Member

    Code:
    <?php
    include("soap.lib.php");
    
    $server_url = "http://www.domain.com:81";
    
    $soapclient = new soapclient($server_url.'/remote/index.php');
    
    $parameters = array('user' => 'admin',
    'pass' => 'admin');
    
    $session_id = $soapclient->call('login',$parameters);
    
    if($err = $soapclient->getError()) die("Error: ".$err);
    
    $params = array ( 'sid' => $session_id,
    'module' => 'reseller',
    'function' => 'reseller_list',
    'params' => '');
    $reseller_list = $soapclient->call('service',$params);
    
    if($err = $soapclient->getError()) die("Error: ".$err);
    print_r($reseller_list);
    $soapclient->call('logout',array('sid' => $session_id));
    
    if($err = $soapclient->getError()) die("Error: ".$err);
    
    echo "<br>Script end ...";
    ?>
     
  5. 3cwired_com

    3cwired_com New Member

    Any ideas?
     
  6. 3cwired_com

    3cwired_com New Member

    The post I am about to reply to was copied in from another thread:
    I did install the remoting framework, and created 2 users to make sure, :eek: .
    Code:
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL} ${WITH_ZLIB_DIR}  --without-pear || error "Could not configure PHP"
    
    I see in your file you also removed "with_zlib_dir" and "--without -pear" I think I may try reinstallation again with those options.
     
  7. 3cwired_com

    3cwired_com New Member

    Ok apparently using your compile file my installation failed with:
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

    I am going to try it removing the "--without -pear" switch.
     
  8. 3cwired_com

    3cwired_com New Member

    When I try it for the 2nd time I get this

    : warning: the use of `mktemp' is dangerous, better use `mkstemp'
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/zip-2.3'
    cc -o unzip unzip.o crc32.o crctab.o crypt.o envargs.o explode.o extract.o fileio.o globals.o inflate.o list.o match.o process.o ttyio.o unreduce.o unshrink.o zipinfo.o unix.o -s
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!


    when I try it again for the 3rd time i get this
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot overwrite directory `ispconfig/tools/spamassassin/spamassassin'
    mv: cannot overwrite directory `ispconfig/tools/uudeview/uudeview'
    mv: cannot overwrite directory `ispconfig/tools/clamav/clamav'
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
     
  9. 3cwired_com

    3cwired_com New Member

    despite all of my woes with reinstalling ispconfig, the best I can get which I have gotten before is:
    Error: HTTP Error: no data present after HTTP headers.

    I might try reinstalling again for what seems like the hundredth time! :(
     
  10. till

    till Super Moderator

    I do not think that reinstalling is nescessary. Did you solve the compile problems above?

    If not,

    1)make sure that you install from e.g. /tmp or /usr/src, installing from directories like /home/admispconfig or /root might be problematic.
    2) Configure your server as described in one of the perfect setup howtos.
    3) To use the remoting framework, it is not nescessary anymore to install a ioncube encoder as you might have read in older threads.
    4) If you will be sure that you do not get trouble with ssl certificates when you connect to the remoting service, choose "http" when you install ispconfig and not 'https'. This will make it easier to debug things and we can be sure that your problems are not caused by missing SSL support in the PHP that you use on the client side for your soap script.
     
  11. 3cwired_com

    3cwired_com New Member

    I tried your compile script, got a new installation to finish, installed the remoting plugin, added a user, tried it out, again still no cigar. now I have to try to recover my ispconfig as it removed my previous settings.
     
  12. 3cwired_com

    3cwired_com New Member

    Well most of the info out says to reinstall and edit the compile script in order to reconfigure ispconfig to work with the remoting plugin. So thats why i have been reinstalling and causing a mess... I must have reinstalled ispconfig atleast 15 times collectively. Initially when I was doing the install I did the install as http, but on my last two attempts I did the install as https, still no cigar. I didn't try the ioncube encoder as per what the threads said. I almost did as a last resort.
     
  13. falko

    falko Super Moderator

    Please check your /tmp directory. There should be backups of /root/ispconfig, /home/admispconfig, and your ISPConfig database so that you can recover your previously working installation. :)
     
  14. 3cwired_com

    3cwired_com New Member

    Thanks for your reply, I will get that underway in a couple of days when i get a chance to look at it again, but i definitely want to get the remoting plugin working first. I dont have many sites on the server yet, so me loosing a few settings isnt on the top of my priority. If i can get help figuring this out then atleast I will know where to go to get it working once I have to redo the new server which is almost complete.

    I feel like I have tried everything and nothing works.... :eek:
     
  15. 3cwired_com

    3cwired_com New Member

    Call me stupid

    Ok, let me guess if I figured this out, I think I may have got the remoting plugin working.

    For some odd reason I tested it out by adding the test files into the ispconfig remote folder. it worked there, I don't think it worked out before in a regular web directory. So i tried it on another domain and it worked, so i came back to the home/main domain, and it worked there as well. So it worked but I am not totally sure why it did, and why not and not with all of my subsequent attempts and tries, maybe I had to use the exact compile script(provided by larwilliams) on my initial installation.

    Nonetheless, i think parts of my screw ups were when it wasn't working, I then started playing with the variables for the remoting server url, not knowing that there is a folder that exits in ispconfig entitled www.domain.tld:81/remote , so when I kept looking I was always tempted to change it(which I did a couple of times) to no avail not fixing any problems.

    I think somewhere one should make it explicit unless you change that path on your system manually, then there is or maybe absolutely no need to change it in the index.php file. Just my .02 cents. I am just overly happy that the system works now.

    When I was also doing my testing, this happened on the https version I had setup at the time... I got the following message. What are the steps needed to get this corrected?

    Error: CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

    I googled some info which I will try later.

    Thanks for all of your patience and support, you all are the best!

    Now I just have to restore my old ispconfig install.
     
  16. 3cwired_com

    3cwired_com New Member

    Ok it works great, I am happy now. I have restored my ispconfig install, and the remoting plugin works great! I am all happy now. I just need to go ahead and try to set it up with the CURL Extension for SSL so that I can login and test it with SSL.
     
  17. Rockdrala

    Rockdrala New Member

    Could you please post the steps taken for fixing the problem?
     
  18. matiasCU

    matiasCU New Member

    Same problem!

    3cwired_com, I have the same problem with versión ispconfig_remoting_ext_beta4.2_os.pkg could you find some solution?

    Thanks
     
  19. till

    till Super Moderator

    The output is fine, you can not access the remoting URL with a webbrowser.
     
  20. matiasCU

    matiasCU New Member

    Remember you the solution?


    Remember you the solution? Because I am taking your same problem (Error: CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS). I do not support extensions curl in the apache of ISPConfig, it is possible to add without re-compile it?
    Could you explain how you've done work?
    Thanks
     

Share This Page