Ispconfig - Relay recipients SPAM tagging

Discussion in 'General' started by richelieu, Jul 1, 2014.

  1. richelieu

    richelieu New Member

    Hello,

    I have following scenario with ISPConfig platform:
    1. ispconfig server is responsible for several domains (email ends on this server)
    2. ispconfig acts as a gateway for other domains and email should be cleaned up and relied to target email server

    In case 1 amavis together with spamassassin tags SPAM email messages and add X tag within email´s header

    In case 2 amavis just process antivirus check (X tag in email´s header) but not spam test and no SPAM tag and SPAM score is processed

    Can you help me how to do it?

    Thank you
    marek
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Add the addresses or email domains that you want to scan under spamfilter users in ispconfig.
     
  3. richelieu

    richelieu New Member

    Correct way

    Hi,
    thank you for answer.

    I have put there a string @domain.com and set LOCAL to NO

    Is it correct?

    marek
     
  4. richelieu

    richelieu New Member

    Update

    Hi again,

    I set amavis to more logging details and see that clamd and spamassassin are handling message now.

    What is problem that the subject of the email is not filled by my configured sequence from "normal" policy settings

    AND X tag is not put into email header even spamassassin's result is

    Jul 1 13:55:54 mail amavis[7298]: (07298-10) spam_scan: score=6.084 autolearn=no tests=[BAYES_50=0.8,HTML_FONT_LOW_CONTRAST=0.001,HTML_FONT_SIZE_LARGE=0.001,HTML_MESSAGE=0.001,MIME_HTML_ONLY=0.723,RAZOR2_CF_RANGE_51_100=0.5,RAZOR2_CF_RANGE_E8_51_100=1.886,RAZOR2_CHECK=0.922,URIBL_JP_SURBL=1.25] recips=0
    Jul 1 13:55:54 mail amavis[7298]: (07298-10) bounce unverifiable, <[email protected]_a.org> -> <[email protected]_b.org>
    Jul 1 13:55:54 mail amavis[7298]: (07298-10) do_notify_and_quar: ccat=Spammy (5,0) ("5":Spammy, "1,1":CleanTag, "1":Clean, "0":CatchAll) ccat_block=(), qar_mth=


    Do you know why?

    thanks so much
    marek
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Locaal has to be yes. Local no means no spam tagging.
     
  6. richelieu

    richelieu New Member

    X tag

    Hi there,
    thank you for your reply.

    I have tested the behaviour and now it is working.

    There is only one difference:
    - when the domain is local one, the X-Spam-Flag is set to YES
    - when the domain is remote (relied emails), the X-Spam-Flag is set to NO

    Why is this difference in place?

    thank you
    marek
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Remote (local = no) means outgoing email. outgoing email is never tagged as this might influence the receiver. so all emails that you want to filter must have set local = yes.
     
  8. richelieu

    richelieu New Member

    Uff

    Hi,

    so I am confused now...

    How to tag as a spam message what doesn´t stored locally? I mean - set the X-Spam-Flag to YES even it is remote domain?

    Thank you,
    marek
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats what I explained already twice above. A domain for incoming email is always local, if you forward, store or delete that email afterwards does not matter for spam scanning.
     
  10. richelieu

    richelieu New Member

    Great

    Hi there,

    it is working well and header is tagged with X description (even not set as YES).

    I have additional question how to do antivirus and spamcheck for users who are authenticated over submission port.

    Thanks in advance

    marek
     

Share This Page