ISPConfig puts IP in Vhosts_ispconfig.conf VirtualHost-tag instead of domainname

Discussion in 'Installation/Configuration' started by Cybertinus, Apr 16, 2006.

  1. Cybertinus

    Cybertinus New Member

    Hello everybody,

    The Title say's it all :). If I creat a new website in ISPConfig, ISPConfig writes the IP to /etc/apache2/vhosts/Vhosts_ispconfig.conf in the <VirtualHosts> tag, instead of the new domain. so the VirtualHost tag looks like this:
    in stead off:
    <VirtualHost www.domain.tld:80>
    If I have the IP in the VirtualHost tag and I go to domain.tld, I get to see the default Apache 2 page (I think that is the problem in this and this thread). If I change the IP to the domain then everything works fine. I think this is a bug in ISPConfig itself.
    Can someone tell me if this is a bug, or do I have a setting somewhere wrong?
  2. falko

    falko Super Moderator ISPConfig Developer

    No, it's not a bug, it's working fine for me. Did you follow any of the "Perfect Setup" tutorials on HowtoForge to set up your system? Maybe it's some kind of misconfiguration.
  3. Cybertinus

    Cybertinus New Member

    hmm. I'm on the phone now with the person who installed the server. He says he has done a lot of testing with user creation and deleting. In the process he has changed the prefix of the users (from "web" to none). We think ISPConfig doesn't like that. So we are going te reinstall the server. Maybe tomorrow, maybe Wensday. I give you the results of the reinstall.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In the ISPConfig sources the username prefix has nothing to do with domain or IP in the virtual host, this can not be mixed up as the values reside in different source files and different database tables. I guess you entered an IP address in the domain field of the website.

Share This Page