ispconfig proxypass

Discussion in 'Installation/Configuration' started by mzakelj, Jul 23, 2012.

  1. mzakelj

    mzakelj New Member

    I have problem. I have a ispconfig and vhosts. But i need one redirect from one vhosts to another windows server that is running the asp aplication. How can i do this ?
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Do you want to just redirect to another vhost (and thus URL) or do you want to proxy the content from one vhost to another so that the user does not directly see that you provide some else vhosts content?

    In case of just redirecting go to the web in the ispconfig 3 menu to the section redirection and select e.g. R=301,L and provide the destination URL.

    In case of proxying, check for the proxy pass directives in the apache documentation and place the appropriate ones in the field for the apache directives in the "options" tab of you specific web.
     
  3. mzakelj

    mzakelj New Member

    The problem is next:

    Router -> ISP3 server (shop pages and other subdomains ) main domain must be redirected to local ip 192.x.x.x .

    Is this correct what you sayed, becose i cannot insert url to redirect, only ip.

    Isp server has shop.domain.com and this is on isp server.
    I want to redirect the domain.com to another ip insede local network, so the clients wont see the redirection.
    The reason is this becose we need to rune f... windows server behind beatiful linux server. grrr :)
     
    Last edited: Jul 24, 2012
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well then you should, as said check the proxy directives from the apache documentation, there are also some examples: http://httpd.apache.org/docs/2.2/mod/mod_proxy.html

    other option could be to redirect to another port on that you do the portforwarding to the windows server. Maybe you might also have to depending on the app's compatibility with a reverse proxy..

    e.g.
    router -> portforwarding 80,443 -> linux
    router -> portforwarding 8080 -> windows
     
  5. mzakelj

    mzakelj New Member

    Problem is that i cannot redirect the port to another port, must be 80 for windows server. The aplication is internet information server. It host asp aplication. Where i insert the proxy pass, in the virtualhost file or in the default page.
     
  6. mzakelj

    mzakelj New Member

    I solved the problem. I eneter the proxy pass in vhost and it works. Thank you :)
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you entered it in the pache directives box in the website settings in ispconfig and not in the vhost file directly, as all changes that you do to a vhost file gets removed automatically.
     
  8. mzakelj

    mzakelj New Member

    When the imputs in vhosts disapear and where in ispconfig i need to input ?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The inputs disappera when you edit a settings for that site in ispconfig. Never edit a vhost file manually, you can do that all inside ispconfig.

    See options tab of website settings.
     
  10. mzakelj

    mzakelj New Member

    Thank you. I will do that.
     

Share This Page