ISPConfig Probs, and its not a port/forward problem.

Discussion in 'Installation/Configuration' started by Code5, Jun 15, 2008.

  1. Code5

    Code5 New Member

    Hi all im kinda new to ISPConfig, and im having a problem connecting to the server via Https://

    All port forwarding is sorted and i can access the server service "ISPConfig" by using the direct URI which is https://192.168.*.*:81 but not by using or

    I have even tried accessing this URI from outside the internal network of ours and still no luck.

    I havent tried a DMZ yet, but this is not the option we wish to take.

    Many thanks for any help on this tedious problem.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you can access ispconfig by IP, then your problem is not in the ispconfig installation, it is most likely a dns problem. Please make sure that the domain name points to the external IP address of your router with a dns A-Record. Then make sure that your router and firewall do not block port 81.
  3. Code5

    Code5 New Member


    I use an external dns system from outside to point to my domain inside.

    All the A records are fine as i have two web servers running, one windows, one linux. The Windows works fine with access to 80,81,8080, and access to its Helm over another port is fine.

    I have setup the Linux the same way, using external dns to point to my IP, then the Linux should resolve locally then retrieve data back the domain which is recognised within the local dns.

    The dns records which are resolving external, to one IP "my IP", back to my dns which is on the same local IP are all accounted for, except one thing which i dont think it will be which is, "Should i add an external record to point an "NS record"? e.g." to my local, external IP?

    Its very strange and im new to Linux.

    All ports are open for the moment, on the Linux with the required forwarding rules.

    Any ideas????

    I keep thinking dns myself.
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you check the A record like this?
  5. Code5

    Code5 New Member

    Fixed. It was our Local DNS on the Linux Host.

    Ive fixed the problem and it was with DNS.

    My Bind9 config was slightly wrong, locally. External DNS was working fine.

    All is well, and ive not had to use DMZ.

    Thanks for your help, much appreciated.

Share This Page