ISPConfig problem

Discussion in 'Installation/Configuration' started by Novaoblivion, Jan 26, 2006.

  1. Novaoblivion

    Novaoblivion New Member

    I followed the breezy setup how to and setup my server. I was able to get everything up and running and surf to the site (I am using DynDNS to host the site on a server I have here). But when I create a site I either get the shared ip message or (if I change the ip to my public one) I get index of / where I see the dir for the site. Now I want it to be so when I surf to the site it goes to the site instead of just giving a directory listing. I use novaoblivion for hostname and gotdns.com for the domain but it just creates a subfolder called novaoblivion.gotdns.com with the site in it. Thanks :)
     
  2. falko

    falko Super Moderator

    If you create a web site novaoblivion.gotdns.com in ISPConfig, you must use exactly that address in your browser's address bar, and of course the DNS records for novaoblivion.gotdns.com must point to your server's public IP address (if you're behind a router, novaoblivion.gotdns.com must point to your router's public IP address, and from your router you must forward port 80 to your ISPConfig server).

    If you just want this to work in your LAN, you can also modify your client's hosts file. You must then use the ISPConfig server's local IP address. Look here: http://www.howtoforge.com/forums/showpost.php?p=2024&postcount=3
     
  3. Novaoblivion

    Novaoblivion New Member

    Hmmm I think all of that is how it should be... maybe I am just messing something up because its late so please excuse my newbishness :) when I point the browser to http://novaoblivion.gotdns.com it gives me the page saying "index of /" in there I see some folders. In order to get to the site I made I have to go to http://novaoblivion.gotdns.com/novaoblivion.gotdns.com/web/ it creates a folder as you can see. Thanks!

    Edit: I do want the site to be visible to the outside world and do have the ports forwarded and I think the DNS correct.
     
    Last edited: Jan 26, 2006
  4. till

    till Super Moderator

    Does the site novaoblivion.gotdns.com that you created in ISPConfig uses the internal IP address of your Server. The IP address where you forwarded the ports from your router to?
     
  5. Novaoblivion

    Novaoblivion New Member

    No I changed it to the external IP that my router gets from my ISP before I did that it would give me the shared IP message now I just get the index of / message.

    Edit: Ok it seems to be working now I dont know why? But thanks for all your help! Sorry to bother you :)
     
    Last edited: Jan 26, 2006
  6. till

    till Super Moderator

    If you are in a NAT enviroment behind a router, the websites must be configured on the internal IP.
     

Share This Page