ispconfig problem after successful installation

Discussion in 'Installation/Configuration' started by jjloupe, Sep 16, 2009.

  1. jjloupe

    jjloupe New Member

    Everything seems to have gone right, then after restarting the server, apache won't start. I get the following error:

    Code:
    Syntax error on line 7 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    Listen requires 1 or 2 arguments.
    
    Here is a copy/paste of 000-isphost.vhost:

    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen /tmp/ispconfig3_install/install# php -q install.php
    NameVirtualHost *:/tmp/ispconfig3_install/install# php -q install.php
    
    <VirtualHost _default_:/tmp/ispconfig3_install/install# php -q install.php>
      ServerAdmin [email protected]
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    
    Any suggestions?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if you entered the string "/tmp/ispconfig3_install/install# php -q install.php" instead of the port 8080 as you installed ispconfig. Please change all occurrences of

    "/tmp/ispconfig3_install/install# php -q install.php" with "8080" in that file and restart apache.
     

Share This Page