ISPConfig Postfix ERROR (Relay access denied)

Discussion in 'Installation/Configuration' started by burzumishi, Aug 2, 2006.

  1. burzumishi

    burzumishi New Member

    I have a trouble with "postfix+courier", I have installed ISPConfig over Ubuntu Breezy following "ISP-Server Setup - Ubuntu 5.10 Breezy Badger" manual and it worked fine for months, but now, server is allowed to send mail but does not recive mails from any remote host (only localhost is allowed to send and recive mail).

    The following lines are /var/log/mail.log error:

    Aug 2 15:33:24 eid postfix/smtpd[8730]: connect from[]
    Aug 2 15:33:27 eid postfix/smtpd[8730]: NOQUEUE: reject: RCPT from[]: 554 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<>
    Aug 2 15:33:28 eid postfix/smtpd[8730]: lost connection after RCPT from[]
    Aug 2 15:33:28 eid postfix/smtpd[8730]: disconnect from[]

    And this is my postfix configuration:

    # postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    home_mailbox = Maildir/
    inet_interfaces = all
    mailbox_command =
    mailbox_size_limit = 0
    mydestination =,, localhost
    myhostname =
    mynetworks =
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (EID)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom

    I reconfigured postfix, sasl and updated ISPConfig to 2.5.5 but trouble persists.

    Hope someone can help me please. :confused:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It seems that you replaced your postfix file with a version that does not use any of the configuration files created by ISPConfig.

    1) Comment the mydestination line.
    2) Add these lines at the end of the file:

    and restart postfix.

Share This Page