ispconfig postconf sasl smtpd mail not working

Discussion in 'Installation/Configuration' started by vinodadhikary, Apr 4, 2008.

  1. vinodadhikary

    vinodadhikary New Member

    Hi I followed Falko's "Fedora 8 Server Setup: LAMP, Email, DNS, FTP, ISPConfig"

    My mail is not working. I have my own DNS server and I do have my host record set as A as well as MX. here is my iptables since it doesn't have the port open but I am really confused because ispconfig shows that my servers are running.

    Code:
    :INPUT ACCEPT [0:0]
    :FORWARD ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    :RH-Firewall-1-INPUT - [0:0]
    -A INPUT -j RH-Firewall-1-INPUT
    -A RH-Firewall-1-INPUT -i lo -j ACCEPT
    -A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 110 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 81 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 25 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 53 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 53 -j ACCEPT
    
    I've had problems with this mail for a while now, I tried figuring out myself but no luck yet. Gurus, help please.
     
  2. till

    till Super Moderator

    Please have a look into your maillog. Which messages or errors appear when you send a email?
     
  3. vinodadhikary

    vinodadhikary New Member

    actually I uninstalled postfix and installed again according to falko's perfect server setup for fc8. Now I just figured out that when I perform
    Code:
    telnet localhost 25
    I get the desired result. but when I do


    Code:
    telnet vibhas.webinformatix.com
    I get:

    am I missing something?
     
  4. vinodadhikary

    vinodadhikary New Member

    okay got this to work after adding my networks ip to the mynetworks. the new problem is that
     
  5. falko

    falko Super Moderator

    Please enable "Server requires authentication" in your email client.
     
  6. vinodadhikary

    vinodadhikary New Member

    I have that set already in my email client. I believe you are referring to that. I restarted my machine now my maillog is:
     
  7. vinodadhikary

    vinodadhikary New Member

    well i've got that to working. I created a local-host-names and actually had to add a dummy host within ispconfig so that the local-host-names be populated.

     
  8. vinodadhikary

    vinodadhikary New Member

    funny thing, I got this to work but I really dont' know how. I added the local-host-names to mydestination in /etc/postfix/main.cf and restarted postfix after doing a postfix reload. Its working!!! Now the new problem is I am trying to send email to my hotmail account with the mail myaddress@hotmail.com. the maillog doesn't show anything wrong but I don't see any new emails in my hotmail account and when I try to send a message from hotmail to my domain account myaddress@mydomain.com, no error so far but don't see anything in my mailbox.

    I tried connecting to port 25 from external network but the connection times out and could not connect. I have checked my iptables and called my isp to see if they have blocked it, but no they haven't.
     
  9. vinodadhikary

    vinodadhikary New Member

    all solved. thanks you guys.
     

Share This Page