ISPConfig possible e-mail problems

Discussion in 'Installation/Configuration' started by mr_bo, Aug 18, 2009.

  1. mr_bo

    mr_bo New Member

    Hi, I am running ispc3 all ok on centos 5.3 but one thing niggles me, some e-mail recipiants do not receive mails. At a guess i would say 10% ish of mails do not get delivered.

    What reason could that be? I am not blacklisted and port 25 is not blocked.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Look at your mail log and the spamfiltering settings.
  3. mr_bo

    mr_bo New Member

    Hi Till,

    The spam filter is not enabled and in the mail log I can find the section for a known recipient that does not receive mails but don't really know what to look for.

    Also don't want to post it publicly but if you would take a look by pm it would be appreciated.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am sorry, I dont offer free support by pm. You can either post the info here or order contact us trough the website if you like to get commercial support.
  5. mr_bo

    mr_bo New Member

    Appreciate your comments there till, can you suggest anything obvious for me to look at?

    Thanks in advance.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Compare the lines for delivered emails with the lines for not delivered emails to find the differences.
  7. mr_bo

    mr_bo New Member

    Right, I have studied the log files for a known delivered mail and a known undelivered mail and all I can see is right at the end of the log for the undelivered mail is:
    Code:[]:25, delay=1.9, delays=0.06/0.1/1.2/0.58, dsn=2.0.0, status=sent (250 ok [B]dirdel[/B])
    And for the delivered mail:
    Code:[]:25, delay=1.6, delays=0.06/0.03/0.98/0.49, dsn=2.0.0, status=sent (250 ok:  [B]Message 460732577 accepted[/B])
    Does this mean anything? As the rest of the logs look ok to me.

    Thanks in advance.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Both emails are delivered correctly (status 250 ok). The delivery of the firts mail was accepted by the yahoo server, so if the mail does not show up in your yahoo account, it has been filtered by a spamfilter at yahoo.

    To prevent that other providers filter out your email, make sure that your IP is not blacklisted and that you have a correct PTR record for the IP of your server.
  9. mr_bo

    mr_bo New Member

    Thanks till, I think PTR needs looking at as currently has been overlooked.

    In the ispc dns manger can you please tell me what goes in each field. I have tried looking but get confused with reverse dns stuff. :)
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The reverse record has most likely to be set in the dns server of the provider that assigned you the IP address and not in your local dns server. Ask your provider to set this for you in his dns server.
  11. mr_bo

    mr_bo New Member

    till, I spoke with my provider and they can set 1 domain name in their rev dns zone. Is it correct for a domain name to go in there? How will that help my other domains on the ispc server?
    And do I have to use my isp's dns server as currently using opendns servers.

    Thank you, this is all so confusing for me :)
    Last edited: Aug 27, 2009
  12. mr_bo

    mr_bo New Member

    Any ideas?
  13. Craig

    Craig New Member

    I had the same "problem", only one reverse DNS name per IP but half a dozen domains hosted on that IP.

    The simple answer is, it just doesn't matter.

    What does matter is that whatever reverse DNS name you use, it not appear to be a random string, even partially, or some MTAs will think it a dynamicaly assigned reverse DNS as is normally seen from "dialup" a.k.a. infected systems.

    For what it may or may not be worth, what I did was picked the domain name with the best reputation on the server and added "mail" as a sub-domain and used that.

    Another idea, if you provide hosting services, use the domain name of the site you use to provide your services through.

    Another good idea is to set up a "txt" and "spf" record in your DNS so that MTAs that your MTA talk to can know that it is authorized to be sending mail for the domain(s) it is sending them for but that is not guaranteed to help in all cases. At least it doesn't hurt, assuming they are set up correctly.
  14. mr_bo

    mr_bo New Member

    Thank you Craig, some good tips there I will try.

    I created a txt in my dns zone, however when performing an spf look up it does not find a txt record when there is one.
    Any ideas why?
  15. mr_bo

    mr_bo New Member

    I am getting no output from dig TXT or any online spf checkers when there is an spf record setup in my dns zone as a TXT.

    Any ideas?

    Thanks in advance.
  16. falko

    falko Super Moderator ISPConfig Developer

    Please check if your nameservers are authoritative for your domain:
    dig ns
  17. mr_bo

    mr_bo New Member

    All is ok with nameservers falko and all is ok with resolving txt entries.

    Have also got a rev dns ptr for set with my isp and -x resolves good too.

    Set all other domain mx records in ispc to and spf with the mechanism which also resolves good.

    Mail still dropping in yahoo spam box which is rather annoying so tried to set up but cannot get it to work, as soon as I comment out the postfix file I can send/receive mails ok, but with set up as per howto it stops sending mails, mail log shows an error with inet:localhost:20209

    Cant get this working either.


    Any ideas?

    Using the DKIM implemantation I am getting this error in maillog:-

    Oct 11 13:54:46 server3 postfix/smtpd[9303]: fatal: host/service localhost/20209 not found: No address associated with hostname
    Last edited: Oct 14, 2009
  18. mr_bo

    mr_bo New Member

    Why is my maillog logging an hour difference with this error?

    Oct 13 21:06:56 server3 postfix/smtpd[8232]: connect from unknown[]
    Oct 13 20:06:56 server3 postfix/smtpd[8232]: fatal: host/service localhost/20209 not found: No address associated with hostname
    Oct 13 21:06:57 server3 amavis[2441]: (02441-01) rw_loop: receiving
    Oct 13 21:06:57 server3 amavis[2441]: (02441-01) rw_loop read: got eof
    Oct 13 21:06:57 server3 amavis[2441]: (02441-01) smtp resp to greeting:
    Oct 13 21:06:57 server3 amavis[2441]: (02441-01) mail_via_smtp: session failed: Negative greeting:  at (eval 74) line 596, <GEN12> line 2750.
    Oct 13 21:06:57 server3 amavis[2441]: (02441-01) prolong_timer fwd-end-chkpnt: timer set to 478 s

Share This Page