ISPConfig port 8080 not reachable after Debian Stretch update

Discussion in 'Installation/Configuration' started by _julian, Jun 9, 2018.

  1. _julian

    _julian New Member

    Hi,

    I've just updated my server from Wheezy to Stretch in two steps. Step one was to go to Jessie, which worked well and ISPConfig was working as expected after the update. Second step was the update to Wheezy, where I had some trouble with updating apache, which in the end caused me to purge apache. Now after having reinstalled apache and run the update.php to reconfigure services, it still does not make apache listen to port 8080.

    sites-enables directory looks like this:
    Code:
    ls -lh /etc/apache2/sites-enabled/
    total 0
    lrwxrwxrwx 1 root root 39 Jun  9 22:58 000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
    lrwxrwxrwx 1 root root 35 Jun  9 22:55 000-default.conf -> ../sites-available/000-default.conf
    lrwxrwxrwx 1 root root 43 Jun  9 22:58 000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
    I'm wondering how the vhost vs conf file ending is handled? It appears the sites-available/ispconfig.vhost would be responsible for enabling port 8080, but this does not appear to be activated?!

    Thanks for your thoughts,
    Julian
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. ahrasis

    ahrasis Well-Known Member

    If you use purge apache2 instead of remove, normally the vhost files will be deleted. So do check and if that's true, do restore your vhost files.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    You have a sites-enabled symlink for 000-ispconfig.conf; you should also have one for 000-ispconfig.vhost, try creating that.
    Code:
    ln -s /etc/apache2/sites-enabled/000-ispconfig.vhost /etc/apache2/sites-available/ispconfig.vhost
    Then restart apache. If that doesn't do it, check /var/log/apache2/error.log and follow the above advice.
     

Share This Page