ISPConfig/POP3 and IMAP problems!

Discussion in 'General' started by grantus, Sep 3, 2008.

  1. grantus

    grantus New Member

    Ok, I had this all working perfectly last week but then for some stupid reason I decided to try another control panel. I deleted ISPConfig and realised that nothing worked anymore since ISPConfig installs it's own apache etc etc and that it is very integrated. Anyway I decided to go back to ISPConfig after all this mess just to get the server up and running again.

    I have so far successfully got everything back to normal except for one thing. It seems that my SMTP works fine but my POP3 and IMAP are not working. I go to and type in my username and password that I have created in the user&email tab in ISPConfig and it returns "Error: Password error: Login failed." I am certain that I have put in the correct username and password since this username and password works for the ftp server and it seems to send with smtp ok, it just doesn't work for incoming mail or the mailuser login.

    The username I have at the moment is web4_grantus. It is like even though I deleted the old apache, postfix servers the computer still remembers my old site logins that I made on the old server (being web1_grantus and web2_ja - which was to be my brother's site). I say this because I go into /etc/shadow and have deleted these references and saved it and go back into my ISPConfig to create user web4_grantus again then I look back in /etc/shadow and find not only web4_grantus there but references to the old web1_ and web2_ as well appearing. (I'm not sure if this has any relevance to the problem).

    In the end I just can't seem to get incoming mail working and I have no idea why. I've been trying to get this working ALL DAY and still have got nowhere. I can't believe I've wasted an entire day on this.

    I guess at least the website is working. But I really would like to get the complete package working and be able to receive email to my domain in Outlook or something like that. (I'm sure it's not an Outlook problem either since mailuser login doesn't work and I've tried telnetting to port 110 and logging in to no avail either - it just says ERR Login failed all the time).

    If somebody can help me here I will be sure to give you honorable mention in my blog and all future endeavours on my domain :).

    I look forward to hearing what you guys think.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not that integrated in the linux distribution and the ispconfig webserver is only for the controlpanel, the normal webserver on port 80 is not affected. You seem to mix up the server on port 81 and 80. ISPConfig can be uninstalled completely by simply running: /root/ispconfig/uninstall

    Most likely the other controlpanel you tried has replaced the configuration of your pop3 and imap daemon or it even replaced the complete daemons. There are two options:

    1) The reliable and predictable option is to format the servers and start from scratch.

    2) As ISPConfig works with the linux defaults and does not replace the config files like most other panels, you will have to get back the default config files from your linux distribution so that the pop3 and imap daemon authenticate against /etc/shadow again. For this you might have to find out which config files had been replaced by the other controlapnel (e.g. contact the developers of this panel and ask them if their installer keeps backups) and replace them with the default config files from the linux distribution. Depending on the linux distribution, you will have to replace files in /etc/courier or the dovecot configuration or the pam config files and files in /etc/postfix and the saslauthd configuration if smtp-auth is affected by the problem too.
  3. grantus

    grantus New Member

    Thanks Till!
    This problem seems to make a lot more sense. Will reinstall today and post back.
  4. grantus

    grantus New Member

    Works! :)

    Works like a charm now!
    Thanks Till. :). What an awesome control panel ispconfig is.

Share This Page