Ispconfig phpmyadmin cannot login with db user dan password

Discussion in 'Installation/Configuration' started by JULINT, Nov 12, 2021.

  1. JULINT

    JULINT Member

    Hi,
    I have installed ispconfig from url : https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/
    It seems everything is ok.. until i have login to ispconfig, create database user and create database for one domain.
    Then i am trying to access domain's phpmyadmin using db user dan password for it.
    But cannot login..
    Please help me what is wrong?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. JULINT

    JULINT Member

    I have run test script with its result.


    Code:
    ##### SERVER #####
    IP-address (as per hostname): [localhost]
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Ubuntu 20.04.3 LTS
    
    [INFO] uptime:  22:33:45 up  2:20,  2 users,  load average: 0.00, 0.03, 0.00
    
    [INFO] memory:
                  total        used        free      shared  buff/cache   available
    Mem:          981Mi       308Mi       142Mi        23Mi       530Mi       505Mi
    Swap:         511Mi       501Mi        10Mi
    
    [INFO] systemd failed services status:
      UNIT                  LOAD   ACTIVE SUB    DESCRIPTION
    ● clamav-daemon.service loaded failed failed Clam AntiVirus userspace daemon
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    
    1 loaded units listed.
    
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.7p1
    
    [WARN] Could not connect to mysql with given user data.
    [WARN] Could not use mysql command line to connect to the database. Check your mysql config!
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.4.25
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.25
    
    ##### PORT CHECK #####
    
    
    ##### MAIL SERVER CHECK #####
    
     
  4. JULINT

    JULINT Member

    Hi ,

    When i am logging to database mysql using user root.
    1. mysql -u root -p
    2. use mysql; ( select database )
    3. select * from user;
    there is no data user for db user i have created from ispconfig
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have a multi-server install? If so, be sure you selected the correct database server when creating the database. If not, or if that doesn't find the problem, enable server debugging (there's a link explaining how to do so in that "read before posting" post) and see what happens when running server.sh manually when you create a new database. (use server debugging on the database server, if it's a multi-server install)
     
  6. JULINT

    JULINT Member

    Hi Jesse,
    Below is the result of Run the server script manually to get detailed debug output


    Code:
    12.11.2021-21:03 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    12.11.2021-21:03 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished server.php.
    
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess there is a misunderstanding here. DB users get created when you add a database that this user has access to. Probably you missed creating a database yet and that's why you have no DB user. Login to ISPConfig, go to the sites module, create a new database. select this DB user in the database settings. save the new database. wait until changes are written to disk, and you will then be able to login to phpmyadmin with that database use to access the database you created.
     
    JULINT likes this.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    And regarding debugging, you must do the action that you want to debug to get debug output for this action. This means, you must create a new database user and a new database to debug the process.
     
  9. JULINT

    JULINT Member

    Hi Till,
    I have uploaded image for database ..

    Then i am trying login to phpmyadmin, and i got mysqli_real_connect(): (HY000/1045): Access denied for user 'c1ddcart_dev'@'localhost' (using password: YES)
     

    Attached Files:

    • db.png
      db.png
      File size:
      13.9 KB
      Views:
      3
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    That looks ok. Please create a new database for this user. Then run server.sh (debug mode should still be on) and post the output that you get on the shell then.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    And just to mention, debug mode must be on for that server and server.sh must be run on that server to get the debug output and not on the master :)
     
  12. JULINT

    JULINT Member

    Hi Till,


    Code:
    [email protected]:~# /usr/local/ispconfig/server/server.sh
    12.11.2021-21:28 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.4/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.4/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/5.6/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/5.6/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.0/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.0/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.1/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.1/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.2/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.2/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.3/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/7.3/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/8.0/cgi/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - safe_exec cmd: grep ^opcache.validate_root '/etc/php/8.0/fpm/php.ini' - return code: 0
    12.11.2021-21:28 - DEBUG - Found 5 changes, starting update process.
    12.11.2021-21:28 - DEBUG - Calling function 'db_user_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_update'.
    PHP Warning:  mysqli::__construct(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 713
    12.11.2021-21:28 - ERROR - Unable to connect to mysqlAccess denied for user 'root'@'localhost' (using password: YES)
    12.11.2021-21:28 - DEBUG - Processed datalog_id 69
    12.11.2021-21:28 - DEBUG - Calling function 'db_user_insert' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_insert'.
    12.11.2021-21:28 - DEBUG - Processed datalog_id 70
    12.11.2021-21:28 - DEBUG - Calling function 'db_user_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_update'.
    PHP Warning:  mysqli::__construct(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 713
    12.11.2021-21:28 - ERROR - Unable to connect to mysqlAccess denied for user 'root'@'localhost' (using password: YES)
    12.11.2021-21:28 - DEBUG - Processed datalog_id 71
    12.11.2021-21:28 - DEBUG - Calling function 'db_insert' from plugin 'mysql_clientdb_plugin' raised by event 'database_insert'.
    PHP Warning:  mysqli::__construct(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 265
    12.11.2021-21:28 - ERROR - Unable to connect to mysqlAccess denied for user 'root'@'localhost' (using password: YES)
    12.11.2021-21:28 - DEBUG - Processed datalog_id 72
    12.11.2021-21:28 - DEBUG - Calling function 'db_user_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_update'.
    PHP Warning:  mysqli::__construct(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in /usr/local/ispconfig/server/plugins-available/mysql_clientdb_plugin.inc.php on line 713
    12.11.2021-21:28 - ERROR - Unable to connect to mysqlAccess denied for user 'root'@'localhost' (using password: YES)
    12.11.2021-21:28 - DEBUG - Processed datalog_id 73
    12.11.2021-21:28 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished server.php.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf on server3 seems to be incorrect.
     
  14. JULINT

    JULINT Member

    I have changed root password after installation ....
    Step by step:
    1. mysql -u root -p
    2. alter user 'root'@'localhost' identified by '***'
    Is it root cause of the problem ?
     
  15. JULINT

    JULINT Member

    Hi Till,

    Thanks for your help..
    I have know the issue... After installation success, i have change db user root from command line..
     

Share This Page