ISPConfig php.ini, where is it!?

Discussion in 'Installation/Configuration' started by Thavi, Jan 16, 2012.

  1. Thavi

    Thavi New Member

    where is the php.ini file in this configuration? http://www.howtoforge.com/perfect-server-ubuntu-11.10-ispconfig-3
    i have allready tried /etc/php5/apache2/php.ini and all that returns is some blue comented text
    i'm looking for
    Code:
    post_max_size = xM
    upload_max_filesize = xM
    i need to increase the maximum size for uploading sql files in phpmyadmin
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Phpmyadmin uses the php.ini file of the Linux distribution, ISPConfig has no own php.ini file.

    Ubuntu has several php.ini files, depending on the PHP mode that you use. The files are:

    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini

    and dont forget to restart apache.
     
  3. Thavi

    Thavi New Member

    thanks for the quick answer till, but...

    both
    Code:
    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    
    return blue comented text with no configuration options
    Code:
    ;;;;;;;;;;;;;;;;;;;
    ; About php.ini   ;
    ;;;;;;;;;;;;;;;;;;;
    ; PHP's initialization file, generally called php.ini, is responsible for
    ; configuring many of the aspects of PHP's behavior.
    
    ; PHP attempts to find and load this configuration from a number of locations.
    ; The following is a summary of its search order:
    ; 1. SAPI module specific location.
    ; 2. The PHPRC environment variable. (As of PHP 5.2.0)
    ; 3. A number of predefined registry keys on Windows (As of PHP 5.2.0)
    ; 4. Current working directory (except CLI)
    ; 5. The web server's directory (for SAPI modules), or directory of PHP
    ; (otherwise in Windows)
    ; 6. The directory from the --with-config-file-path compile time option, or the
    ; Windows directory (C:\windows or C:\winnt)
    ; See the PHP docs for more specific information.
    ; http://php.net/configuration.file
    
    ; The syntax of the file is extremely simple.  Whitespace and Lines
    ; beginning with a semicolon are silently ignored (as you probably guessed).
    ; Section headers (e.g. [Foo]) are also silently ignored, even though
    ; they might mean something in the future.
    
    ; Directives following the section heading [PATH=/www/mysite] only
    ; apply to PHP files in the /www/mysite directory.  Directives
    ; following the section heading [HOST=www.example.com] only apply to
    ; PHP files served from www.example.com.  Directives set in these
    ; special sections cannot be overridden by user-defined INI files or
    ; at runtime. Currently, [PATH=] and [HOST=] sections only work under
    ; CGI/FastCGI.
    ; http://php.net/ini.sections
    
    ; Directives are specified using the following syntax:
    ; directive = value
    ; Directive names are *case sensitive* - foo=bar is different from FOO=bar.
    ; Directives are variables used to configure PHP or PHP extensions.
    ; There is no name validation.  If PHP can't find an expected
    ; directive because it is not set or is mistyped, a default value will be used.
    
    ; The value can be a string, a number, a PHP constant (e.g. E_ALL or M_PI), one
    ; of the INI constants (On, Off, True, False, Yes, No and None) or an expression
    ; (e.g. E_ALL & ~E_NOTICE), a quoted string ("bar"), or a reference to a
    ; previously set variable or directive (e.g. ${foo})
    
    ; Expressions in the INI file are limited to bitwise operators and parentheses:
    ; |  bitwise OR
    ; ^  bitwise XOR
    ; &  bitwise AND
    ; ~  bitwise NOT
    ; !  boolean NOT
    
    ; Boolean flags can be turned on using the values 1, On, True or Yes.
    ; They can be turned off using the values 0, Off, False or No.
    
    ; An empty string can be denoted by simply not writing anything after the equal
    ; sign, or by using the None keyword:
    
    i have already tried to add my necesary modificantions to this ones but with no outcome
     
  4. Thavi

    Thavi New Member

    php info file
    subun.jpg
    I have added my modifications to /etc/php5/cgi/conf.d/mysql.ini also but still nothing changed and that file contains only one line extension=mysql.so

    phpmyadmins gives me this "file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16."
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    According to the phpinfo() output, your system uses this file: /etc/php5/cgi/php.ini, so the lines have to be added or changed there.
     
  6. Thavi

    Thavi New Member

    not working
    "the file size exceeded the maximum size permitted by your PHP configuration":mad:
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you put the info.php file in the phpmyadmin folder (/usr/share/phpmyadmin....) on a Ubuntu system) and not somewhere else and did you restart apache?
     

Share This Page