ISPconfig Permission ssh www direcotry

Discussion in 'Installation/Configuration' started by sirchuck, Mar 13, 2014.

  1. sirchuck

    sirchuck New Member

    I am not able to access my web directory via ssh from my chuck account. The owner is web21 and the group is client0.

    I tried adding the client0 group to chuck but that doesn't seem to work.

    If I run a chown -R www-data:www-data /var/www command it will allow me to access the folders fine, however when i view my site it gives me a error cant find the file.

    I looked in the group file and ISPConfig has www-data as a group, I also ran
    adduser ispconfig www-data to be sure, but i cant seem to make it so both ispconfig is happy and my ssh access is happy :(
     
  2. sirchuck

    sirchuck New Member

    We are in luck, turns out Im stupid :)

    I gave myself access to the client0 group, but never changed the file permissions to allow the group write access to the files.

    Everything works now.

    I set it to chmod -R 0775, not sure if thats the best setting but it does the trick.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I hope that you havent done that on a server that you want to use, as this command irreversibly destroyed all sites on the server. the only option to repair it is to restore a backup of the /var/www flder, f you have one or to delete all websites that you created in ispconfig and recreate them.

    Back to yur origina problem, there are no modifcations ofy any users or groups nescessary. All you have to do is to add a ssh user in ispconfig to that website, if you want to access it by ssh. You can not access the site with a ssh users that you created manually on your system, as the manually created user has a wrong userid.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This opened up the server for your manually created user and also for many kinds of hacker attacks and its possible now to attack your server trgh a simple website hack. I hope you do not want to connect the server to the internet and host any clients on it in the current state.
     
  5. sirchuck

    sirchuck New Member

    What permissions do you use on your web folder ? 0600?

    I think in my rebuild I added ispconfig to my user group so it could read files I upload.

    I didn't realize ispconfig had that much control over ssh users. After scanning the internet, your the first that has had decent input on this.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    the default permissions, which are 610 in ispconfig 3.0.5.3 and 611 on 3.0.5.4.
     

Share This Page