ISPConfig/perfect setup: outbound e-mail

Discussion in 'Installation/Configuration' started by unhookt, Apr 23, 2007.

  1. unhookt

    unhookt New Member

    I installed ispconfig under the perfect setup instructions but my SMTP server is not authenticating outbound e-mail against user credentials, only against domain name. Can you tell me where I can change this setting in ISPConfig so that outbound messages require user/passwd to be relayed?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    SMTP Authentication is always enabled when you follow the perfect setup guide. Please compare your postfix setup with the perfect setup instructions.

    Be aware that SMTP authentication is never needed for any local domain names, otherwise your server wont be able to receive any email for local mailboxes.
  3. unhookt

    unhookt New Member

    So you're saying that in the perfect setup it's supposed to allow anyone using a pop email client such as entourage or outlook to be able to claim to have an email address that resides within my domain and send outbound mail, even if there is no such user or address in the ispconfig list? This is what is happening.

    that doesn't seem right...

    In MS Exchange server, I am able to configure the server such that the username and password are required from the email client in order to send outbound mail. How can I do that in the perfect setup/ispconfig?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, I dont have said this, I told you the opposite. I said that you must authenticate with username and password and that the requirement to authenticate is configured in the perfect setup.
  5. unhookt

    unhookt New Member

    But does the above mean that local domain users, or those impersonating local domain users, do not have to authenticate?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    No. The above statement is about receiving emails, not sending. If you send a email to a local account, there is never a authentication needed as otherwise your mailserver wont be able to receive emails at all. Thats the case for any linux and windows mailserver in general.

    But some poeple mix these things up and try to do a realay test against a local domain, which is useless.
  7. unhookt

    unhookt New Member

    gotcha - sorry for the confusion.

    my users are able to send email without turning authentication on in their mail clients. I want to force their user ids and passwords to be required. how can I do this?

    I followed the "perfect setup" instructions...
    Last edited: Apr 27, 2007
  8. unhookt

    unhookt New Member

    Anyone? Essentially, I can send mail by configuring my e-mail client with a made up e-mail address that uses my valid domain name. No password required.

    And yes, I'm testing from outside of my local network...

    Here's my file:

    and here are the results when I connect to the SMTP port via SSH on my local machine:

    I really don't want to be a spam source. Can anybody out there help?
  9. JaJunk

    JaJunk New Member

    What is defined as mynetworks?
    more /etc/postfix/ | grep mynetworks

    looks almost the same as mine, which does require outgoing auth from clients. As for the second part, that just tells you tls is working.
  10. unhookt

    unhookt New Member

    Is this supposed to be defined in the same document? If so, I'm missing that piece. (I posted the entire contents of the file above)

    How do I specify mynetworks to allow the machines on my network (192.168.1.x) to allow SMTP relay?

    Last edited: May 10, 2007
  11. JaJunk

    JaJunk New Member

    mynetworks =

    I didn't include the second part on mine b/c I wanted everyone to used outgoing auth. even my computers. Might be a good idea to leave off for testing then add after you know relaying is blocked
  12. unhookt

    unhookt New Member

    Now we're getting somewhere!

    Good idea. So what I did was change:


    to force outbound authentication for all e-mail clients. So far, so good.

    Thanks for your help!:)
  13. JaJunk

    JaJunk New Member

    be sure to allow or else system emails such as alerts will not be sent.
  14. unhookt

    unhookt New Member

    Good point! My now looks like this:

  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Your mynetworks setting is commented out. If you want that it is used by postfix, you will have to remove the "#" in front of the line and restart postfix.
  16. unhookt

    unhookt New Member

    Shouldn't the following have the same effect?

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    It is always better to specify the exact IP addresses and ranges to be sure that the settings are correct instead of hoping thet postfix guessses the settings correctly by reading your network configuration. Of yourse you will ahve to comment out the mynetworks_style line.

Share This Page