ISPConfig panel internal server error

Discussion in 'Installation/Configuration' started by wbtech, Jun 15, 2021.

  1. wbtech

    wbtech New Member

    New install of ISPConfig 3.2.5 on Ubuntu 20.04.2 LTS using the auto-install script. I had a rocky installation, my fault, and had to run the script a couple of times to get it to complete. Control panel does not show up and instead I get an Internal server error. I declined installation of phpMyAdmin.

    /etc/apache2/error.log has lines similar to:
    Code:
    [Tue Jun 15 15:56:07.950917 2021] [fcgid:info] [pid 611140:tid 140019996134464] mod_fcgid: server ******.co.uk:/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter(612738) started
    [Tue Jun 15 15:56:07.952333 2021] [fcgid:warn] [pid 611142:tid 140019710748416] (104)Connection reset by peer: [client ******:50948] mod_fcgid: error reading data from FastCGI server
    [Tue Jun 15 15:56:07.952446 2021] [core:error] [pid 611142:tid 140019710748416] [client ******:50948] End of script output before headers: index.php
    [Tue Jun 15 15:56:10.954334 2021] [fcgid:info] [pid 611140:tid 140019996134464] mod_fcgid: process /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter(612738) exit(communication error), terminated by calling exit(), return code: 255
    I think this is an issue related to permissions:
    Code:
    [email protected]:/var/www# ls -la
    total 24
    drwxr-xr-x  6 root      root      4096 Jun 12 19:50 .
    drwxr-xr-x 14 root      root      4096 Feb  7  2016 ..
    drwxr-xr-x  2 ispapps   ispapps   4096 Jun 14 18:23 apps
    drwxr-xr-x  5 root      root      4096 Jun 12 17:44 clients
    drwxr-xr-x  2 root      root      4096 Aug 12  2020 html
    lrwxrwxrwx  1 ispconfig ispconfig   34 Jun 12 19:50 ispconfig -> /usr/local/ispconfig/interface/web
    drwxr-xr-x  4 root      root      4096 Jun 12 19:50 php-fcgi-scripts
    Code:
    [email protected]:/var/www/ispconfig# ls -la
    total 112
    drwxr-x--- 19 ispconfig ispconfig 4096 Jun 15 15:32 .
    drwxr-x---  9 www-data  www-data  4096 Jun 12 20:05 ..
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 14 13:06 admin
    -rwxr-x---  1 ispconfig ispconfig 3212 Jun 12 20:05 capp.php
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 client
    -rwxr-x---  1 ispconfig ispconfig 2970 Jun 12 20:05 content.php
    drwxr-x---  7 ispconfig ispconfig 4096 Jun 12 20:05 dashboard
    -rwxr-x---  1 ispconfig ispconfig 1901 Jun 12 20:05 datalogstatus.php
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 dns
    -rwxr-x---  1 ispconfig ispconfig    0 Jun 12 20:05 dummy_login.html
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 help
    -rwxr-x---  1 ispconfig ispconfig 4532 Jun 12 22:58 index.php
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 js
    -rwxr-x---  1 ispconfig ispconfig 1649 Jun 12 20:05 keepalive.php
    drwxr-x---  4 ispconfig ispconfig 4096 Jun 12 20:05 login
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 mail
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 14 13:06 mailuser
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 monitor
    -rwxr-x---  1 ispconfig ispconfig 5177 Jun 12 20:05 nav.php
    drwxr-x---  2 ispconfig ispconfig 4096 Jun 12 20:05 remote
    -rwxr-x---  1 ispconfig ispconfig   26 Jun 12 20:05 robots.txt
    drwxr-x---  7 ispconfig ispconfig 4096 Jun 12 20:05 sites
    drwxr-x---  3 ispconfig ispconfig 4096 Jun 12 20:05 strengthmeter
    drwxrwx---  2 ispconfig ispconfig 4096 Jun 12 20:05 temp
    drwxr-x---  3 ispconfig ispconfig 4096 Jun 12 20:05 themes
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 tools
    drwxr-x---  6 ispconfig ispconfig 4096 Jun 12 20:05 vm
    
    but I can't spot it.
    To get the panel working I did this:
    Code:
    a2dismod mpm_event
    a2enmod mpm_prefork
    a2enmod php7.4
    systemctl restart apache2
    a2dismod fcgid
    systemctl restart apache2
    
    and added this to 000-ispconfig.vhost:
    Code:
    DocumentRoot /var/www/ispconfig/
    <Directory /var/www/ispconfig/>
      Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      <FilesMatch "\.php$">
        SetHandler application/x-httpd-php
      </FilesMatch>
      Require all granted
    </Directory>
    
    and it sprang into life but I would like to get it working with FastCGI and suexec.

    Code:
    lsb_release -a
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 20.04.2 LTS
    Release:    20.04
    Codename:    focal
    Code:
    php -v
    PHP 7.4.20 (cli) (built: Jun  4 2021 21:24:55) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.20, Copyright (c), by Zend Technologies
    Code:
    update-alternatives --config php
    There are 7 choices for the alternative php (providing /usr/bin/php).
    
      Selection    Path             Priority   Status
    ------------------------------------------------------------
      0            /usr/bin/php8.0   80        auto mode
      1            /usr/bin/php5.6   56        manual mode
      2            /usr/bin/php7.0   70        manual mode
      3            /usr/bin/php7.1   71        manual mode
      4            /usr/bin/php7.2   72        manual mode
      5            /usr/bin/php7.3   73        manual mode
    * 6            /usr/bin/php7.4   74        manual mode
      7            /usr/bin/php8.0   80        manual mode
    
    Press <enter> to keep the current choice[*], or type selection number:
    [email protected]:~# update-alternatives --config php-cgi
    There are 8 choices for the alternative php-cgi (providing /usr/bin/php-cgi).
    
      Selection    Path                 Priority   Status
    ------------------------------------------------------------
      0            /usr/bin/php-cgi8.0   80        auto mode
      1            /usr/bin/php-cgi5.6   56        manual mode
      2            /usr/bin/php-cgi7.0   70        manual mode
      3            /usr/bin/php-cgi7.1   71        manual mode
      4            /usr/bin/php-cgi7.2   72        manual mode
      5            /usr/bin/php-cgi7.3   73        manual mode
    * 6            /usr/bin/php-cgi7.4   74        manual mode
      7            /usr/bin/php-cgi8.0   80        manual mode
      8            /usr/bin/php5-cgi     50        manual mode
    
    Press <enter> to keep the current choice[*], or type selection number:
    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Ubuntu 20.04.2 LTS
     
    [INFO] uptime:  15:50:45 up 2 days, 10:32,  7 users,  load average: 0.18, 0.12, 0.12
     
    [INFO] memory:
                  total        used        free      shared  buff/cache   available
    Mem:           19Gi       2.5Gi       412Mi        45Mi        16Gi        16Gi
    Swap:         476Mi       287Mi       189Mi
     
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.5
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.4.20
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.20
    
    ##### PORT CHECK #####
    
    
    ##### MAIL SERVER CHECK #####
    
    
    ##### RUNNING SERVER PROCESSES #####
    
    [INFO] I found the following web server(s):
        Apache 2 (PID 611137)
    [INFO] I found the following mail server(s):
        Postfix (PID 54538)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 3058)
    [INFO] I found the following imap server(s):
        Dovecot (PID 3058)
    [INFO] I found the following ftp server(s):
        PureFTP (PID 1496)
    
    ##### LISTENING PORTS #####
    (only        ()
    Local        (Address)
    [anywhere]:4190        (3058/dovecot)
    [anywhere]:993        (3058/dovecot)
    [anywhere]:995        (3058/dovecot)
    [localhost]:11332        (739/rspamd:)
    [localhost]:11333        (739/rspamd:)
    [localhost]:11334        (739/rspamd:)
    [localhost]:10023        (1066/postgrey)
    [localhost]:10024        (1629/amavisd-new)
    [localhost]:10025        (54538/master)
    [localhost]:10026        (1629/amavisd-new)
    [localhost]:10027        (54538/master)
    [anywhere]:587        (54538/master)
    [localhost]:6379        (872/redis-server)
    [localhost]:11211        (720/memcached)
    [anywhere]:110        (3058/dovecot)
    [anywhere]:143        (3058/dovecot)
    [anywhere]:465        (54538/master)
    [anywhere]:21        (1496/pure-ftpd)
    ***.***.***.***:53        (722/named)
    [localhost]:53        (722/named)
    ***.***.***.***:53        (517/systemd-resolve)
    [anywhere]:22        (129583/sshd:)
    [anywhere]:25        (54538/master)
    [localhost]:953        (722/named)
    *:*:*:*::*:4190        (3058/dovecot)
    *:*:*:*::*:993        (3058/dovecot)
    *:*:*:*::*:995        (3058/dovecot)
    *:*:*:*::*:10024        (1629/amavisd-new)
    *:*:*:*::*:10026        (1629/amavisd-new)
    *:*:*:*::*:3306        (911/mysqld)
    *:*:*:*::*:587        (54538/master)
    *:*:*:*::*:6379        (872/redis-server)
    [localhost]10        (3058/dovecot)
    [localhost]43        (3058/dovecot)
    *:*:*:*::*:8080        (611137/apache2)
    *:*:*:*::*:80        (611137/apache2)
    *:*:*:*::*:8081        (611137/apache2)
    *:*:*:*::*:465        (54538/master)
    *:*:*:*::*:21        (1496/pure-ftpd)
    *:*:*:*::*:4949        (984/perl)
    *:*:*:*::*5054:ff:fea0:d:53        (722/named)
    *:*:*:*::*:53        (722/named)
    *:*:*:*::*:22        (129583/sshd:)
    *:*:*:*::*:25        (54538/master)
    *:*:*:*::*:953        (722/named)
    *:*:*:*::*:443        (611137/apache2)
    
    
    
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    f2b-pure-ftpd  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 21
    f2b-postfix-sasl  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 25
    f2b-dovecot-pop3imap  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 110,995,143,993
    f2b-sshd   tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 22
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain f2b-dovecot-pop3imap (1 references)
    target     prot opt source               destination         
    REJECT     all  --  ***.***.***.***      [anywhere]/0            reject-with icmp-port-unreachable
    RETURN     all  --  [anywhere]/0            [anywhere]/0           
    
    Chain f2b-postfix-sasl (1 references)
    target     prot opt source               destination         
    RETURN     all  --  [anywhere]/0            [anywhere]/0           
    
    Chain f2b-pure-ftpd (1 references)
    target     prot opt source               destination         
    RETURN     all  --  [anywhere]/0            [anywhere]/0           
    
    Chain f2b-sshd (1 references)
    target     prot opt source               destination         
    REJECT     all  --  ***.***.***.***          [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***        [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***        [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***       [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***         [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***       [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***      [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***       [anywhere]/0            reject-with icmp-port-unreachable
    REJECT     all  --  ***.***.***.***      [anywhere]/0            reject-with icmp-port-unreachable
    RETURN     all  --  [anywhere]/0            [anywhere]/0           
    
    
    
    
    ##### LET'S ENCRYPT #####
    acme.sh is installed in /root/.acme.sh/acme.sh
    
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have mod_suexec installed and enabled? What is in /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter, and what php packages do you have installed (eg. dpkg --list | grep php)?

    You can run through the perfect server guide for ubuntu 20 + apache and run all the install commands there, to ensure you have all the requirements. The autoinstall script should of course add those, but who knows what happened with the various failures you mentioned.
     
  3. wbtech

    wbtech New Member

    Hi there, thanks for the questions. I'll take a look at the manual install guide too to see if that prompts me as to what might be missing.

    Code:
    a2enmod suexec
    Module suexec already enabled
    I did mess with this file to try and get it working, this is its current contents:
    Code:
    cat /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    #!/bin/sh
    PHPRC=/etc/php/7.4/cgi/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php-cgi \
        -d disable_classes= \
        -d disable_functions= \
        -d magic_quotes_gpc=off \
        -d open_basedir= \
        -d session.save_path=/usr/local/ispconfig/interface/temp \
    
    Code:
    dpkg --list | grep php
    rc  libapache2-mod-php5                    5.5.9+dfsg-1ubuntu4.21                                              amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    rc  libapache2-mod-php7.0                  7.0.33-0ubuntu0.16.04.16                                            amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    rc  libapache2-mod-php7.2                  7.2.24-0ubuntu0.18.04.7                                             amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    ii  libapache2-mod-php7.4                  7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    ii  libapache2-mod-php8.0                  8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        server-side, HTML-embedded scripting language (Apache 2 module)
    ii  libapache2-mod-suphp                   0.7.2-0ubuntu1                                                      amd64        Apache2 module to run PHP scripts with the owner permissions
    rc  php-apc                                4.0.2-2build1                                                       all          APC User Cache for PHP 5 (transitional package)
    ii  php-apcu                               5.1.19+4.0.11-7+ubuntu20.04.1+deb.sury.org+1                        amd64        APC User Cache for PHP
    ii  php-apcu-bc                            1.0.5-13+ubuntu20.04.1+deb.sury.org+1                               amd64        APCu Backwards Compatibility Module
    ii  php-auth-sasl                          1.0.6-3                                                             all          Abstraction of various SASL mechanism responses
    ii  php-bz2                                2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          bzip2 module for PHP [default]
    ii  php-common                             2:82+ubuntu20.04.1+deb.sury.org+1                                   all          Common files for PHP packages
    ii  php-curl                               2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          CURL module for PHP [default]
    ii  php-gd                                 2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          GD module for PHP [default]
    ii  php-google-recaptcha                   1.2.3-1                                                             all          reCAPTCHA PHP client library
    ii  php-imagick                            3.4.4+php8.0+3.4.4-7+ubuntu20.04.1+deb.sury.org+1                   amd64        Provides a wrapper to the ImageMagick library
    ii  php-mail-mime                          1.10.6-1                                                            all          PHP PEAR module for creating MIME messages
    ii  php-masterminds-html5                  2.7.0+dfsg-3                                                        all          An HTML5 parser and serializer
    ii  php-mbstring                           2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          MBSTRING module for PHP [default]
    ii  php-memcache                           8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-1+ubuntu20.04.1+deb.sury.org+2 amd64        memcache extension module for PHP
    ii  php-mysql                              2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          MySQL module for PHP [default]
    ii  php-net-sieve                          1.4.1-1                                                             all          Handles talking to a sieve server
    ii  php-net-smtp                           1.9.0-1                                                             all          PHP PEAR module implementing SMTP protocol
    ii  php-net-socket                         1.0.14-2                                                            all          Network Socket Interface
    ii  php-pear                               1:1.10.12+submodules+notgz+20210212-1+ubuntu20.04.1+deb.sury.org+1  all          PEAR Base System
    ii  php-phpmyadmin-motranslator            5.0.0-1                                                             all          translation API for PHP using Gettext MO files
    ii  php-phpmyadmin-shapefile               2.1-3                                                               all          translation API for PHP using Gettext MO files
    ii  php-phpmyadmin-sql-parser              4.6.1-2                                                             all          validating SQL lexer and parser
    ii  php-phpseclib                          2.0.23-2                                                            all          implementations of an arbitrary-precision integer arithmetic library
    ii  php-psr-cache                          1.0.1-2                                                             all          Common interface for caching libraries
    ii  php-psr-container                      1.0.0-2                                                             all          Common Container Interface (PHP FIG PSR-11)
    ii  php-psr-log                            1.1.2-1                                                             all          common interface for logging libraries
    ii  php-soap                               2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          SOAP module for PHP [default]
    ii  php-symfony-cache                      4.3.8+dfsg-1ubuntu1                                                 all          Symfony Cache component with PSR-6, PSR-16, and tags
    ii  php-symfony-cache-contracts            1.1.8-1                                                             all          Generic abstractions related to caching
    ii  php-symfony-expression-language        4.3.8+dfsg-1ubuntu1                                                 all          compile and evaluate expressions
    ii  php-symfony-service-contracts          1.1.8-1                                                             all          Generic abstractions related to writing services
    ii  php-symfony-var-exporter               4.3.8+dfsg-1ubuntu1                                                 all          export serializable PHP data structure to plain PHP code
    ii  php-tcpdf                              6.3.5+dfsg1-1                                                       all          PHP class for generating PDF files on-the-fly
    ii  php-twig                               2.12.5-1                                                            all          Flexible, fast, and secure template engine for PHP
    ii  php-twig-extensions                    1.5.4-1                                                             all          extensions for the Twig template system
    ii  php-xml                                2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
    ii  php-zip                                2:8.0+82+ubuntu20.04.1+deb.sury.org+1                               all          Zip module for PHP [default]
    ii  php5                                   5.5.9+dfsg-1ubuntu4.21                                              all          server-side, HTML-embedded scripting language (metapackage)
    rc  php5-apcu                              4.0.2-2build1                                                       amd64        APC User Cache for PHP 5
    ii  php5-cgi                               5.5.9+dfsg-1ubuntu4.21                                              amd64        server-side, HTML-embedded scripting language (CGI binary)
    rc  php5-cli                               5.5.9+dfsg-1ubuntu4.21                                              amd64        command-line interpreter for the php5 scripting language
    ii  php5-common                            5.5.9+dfsg-1ubuntu4.21                                              amd64        Common files for packages built from the php5 source
    rc  php5-curl                              5.5.9+dfsg-1ubuntu4.21                                              amd64        CURL module for php5
    rc  php5-fpm                               5.5.9+dfsg-1ubuntu4.21                                              amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php5-gd                                5.5.9+dfsg-1ubuntu4.21                                              amd64        GD module for php5
    ii  php5-imagick                           3.1.2-1build1                                                       amd64        ImageMagick module for php5
    ii  php5-imap                              5.4.6-0ubuntu5                                                      amd64        IMAP module for php5
    ii  php5-intl                              5.5.9+dfsg-1ubuntu4.21                                              amd64        internationalisation module for php5
    ii  php5-json                              1.3.2-2build1                                                       amd64        JSON module for php5
    ii  php5-mcrypt                            5.4.6-0ubuntu5                                                      amd64        MCrypt module for php5
    ii  php5-memcache                          3.0.8-4build1                                                       amd64        memcache extension module for PHP5
    ii  php5-memcached                         2.1.0-6build1                                                       amd64        memcached extension module for PHP5, uses libmemcached
    ii  php5-ming                              1:0.4.5-1ubuntu5                                                    amd64        Ming module for php5
    ii  php5-mysql                             5.5.9+dfsg-1ubuntu4.21                                              amd64        MySQL module for php5
    ii  php5-ps                                1.3.7-1ubuntu1                                                      amd64        ps module for PHP 5
    ii  php5-pspell                            5.5.9+dfsg-1ubuntu4.21                                              amd64        pspell module for php5
    rc  php5-readline                          5.5.9+dfsg-1ubuntu4.21                                              amd64        Readline module for php5
    ii  php5-recode                            5.5.9+dfsg-1ubuntu4.21                                              amd64        recode module for php5
    rc  php5-snmp                              5.5.9+dfsg-1ubuntu4.21                                              amd64        SNMP module for php5
    ii  php5-sqlite                            5.5.9+dfsg-1ubuntu4.21                                              amd64        SQLite module for php5
    ii  php5-tidy                              5.5.9+dfsg-1ubuntu4.21                                              amd64        tidy module for php5
    ii  php5-xcache                            3.1.0-2                                                             amd64        Fast, stable PHP opcode cacher
    ii  php5-xmlrpc                            5.5.9+dfsg-1ubuntu4.21                                              amd64        XML-RPC module for php5
    ii  php5-xsl                               5.5.9+dfsg-1ubuntu4.21                                              amd64        XSL module for php5
    ii  php5.6                                 5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              all          server-side, HTML-embedded scripting language (metapackage)
    ii  php5.6-cgi                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php5.6-cli                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        command-line interpreter for the PHP scripting language
    ii  php5.6-common                          5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        documentation, examples and common module for PHP
    ii  php5.6-curl                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        CURL module for PHP
    ii  php5.6-fpm                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php5.6-gd                              5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        GD module for PHP
    ii  php5.6-imap                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        IMAP module for PHP
    ii  php5.6-intl                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Internationalisation module for PHP
    ii  php5.6-json                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        JSON module for PHP
    ii  php5.6-mbstring                        5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        MBSTRING module for PHP
    ii  php5.6-mcrypt                          5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        libmcrypt module for PHP
    ii  php5.6-mysql                           5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        MySQL module for PHP
    ii  php5.6-opcache                         5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Zend OpCache module for PHP
    ii  php5.6-pspell                          5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        pspell module for PHP
    ii  php5.6-readline                        5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        readline module for PHP
    ii  php5.6-recode                          5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        recode module for PHP
    ii  php5.6-soap                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        SOAP module for PHP
    ii  php5.6-sqlite3                         5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        SQLite3 module for PHP
    ii  php5.6-tidy                            5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        tidy module for PHP
    ii  php5.6-xml                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    ii  php5.6-xmlrpc                          5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        XMLRPC-EPI module for PHP
    ii  php5.6-xsl                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              all          XSL module for PHP (dummy)
    ii  php5.6-zip                             5.6.40-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Zip module for PHP
     
  4. wbtech

    wbtech New Member

    Code:
    ii  php7.0                                 7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.0-cgi                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php7.0-cli                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        command-line interpreter for the PHP scripting language
    ii  php7.0-common                          7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        documentation, examples and common module for PHP
    ii  php7.0-curl                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        CURL module for PHP
    ii  php7.0-fpm                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.0-gd                              7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        GD module for PHP
    ii  php7.0-imap                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        IMAP module for PHP
    ii  php7.0-intl                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Internationalisation module for PHP
    ii  php7.0-json                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        JSON module for PHP
    ii  php7.0-mbstring                        7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        MBSTRING module for PHP
    ii  php7.0-mcrypt                          7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        libmcrypt module for PHP
    ii  php7.0-mysql                           7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        MySQL module for PHP
    ii  php7.0-opcache                         7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Zend OpCache module for PHP
    ii  php7.0-pspell                          7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        pspell module for PHP
    ii  php7.0-readline                        7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        readline module for PHP
    ii  php7.0-recode                          7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        recode module for PHP
    ii  php7.0-soap                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        SOAP module for PHP
    ii  php7.0-sqlite3                         7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        SQLite3 module for PHP
    ii  php7.0-tidy                            7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        tidy module for PHP
    ii  php7.0-xml                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    ii  php7.0-xmlrpc                          7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        XMLRPC-EPI module for PHP
    ii  php7.0-xsl                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              all          XSL module for PHP (dummy)
    ii  php7.0-zip                             7.0.33-51+ubuntu20.04.1+deb.sury.org+1                              amd64        Zip module for PHP
    ii  php7.1                                 7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.1-cgi                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php7.1-cli                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        command-line interpreter for the PHP scripting language
    ii  php7.1-common                          7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        documentation, examples and common module for PHP
    ii  php7.1-curl                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        CURL module for PHP
    ii  php7.1-fpm                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.1-gd                              7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        GD module for PHP
    ii  php7.1-imap                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        IMAP module for PHP
    ii  php7.1-intl                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        Internationalisation module for PHP
    ii  php7.1-json                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        JSON module for PHP
    ii  php7.1-mbstring                        7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        MBSTRING module for PHP
    ii  php7.1-mcrypt                          7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        libmcrypt module for PHP
    ii  php7.1-mysql                           7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        MySQL module for PHP
    ii  php7.1-opcache                         7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        Zend OpCache module for PHP
    ii  php7.1-pspell                          7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        pspell module for PHP
    ii  php7.1-readline                        7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        readline module for PHP
    ii  php7.1-recode                          7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        recode module for PHP
    ii  php7.1-soap                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        SOAP module for PHP
    ii  php7.1-sqlite3                         7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        SQLite3 module for PHP
    ii  php7.1-tidy                            7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        tidy module for PHP
    ii  php7.1-xml                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    ii  php7.1-xmlrpc                          7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        XMLRPC-EPI module for PHP
    ii  php7.1-xsl                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              all          XSL module for PHP (dummy)
    ii  php7.1-zip                             7.1.33-38+ubuntu20.04.1+deb.sury.org+1                              amd64        Zip module for PHP
    ii  php7.2                                 7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.2-bz2                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        bzip2 module for PHP
    ii  php7.2-cgi                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php7.2-cli                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        command-line interpreter for the PHP scripting language
    ii  php7.2-common                          7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        documentation, examples and common module for PHP
    ii  php7.2-curl                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        CURL module for PHP
    ii  php7.2-fpm                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.2-gd                              7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        GD module for PHP
    ii  php7.2-imap                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        IMAP module for PHP
    ii  php7.2-intl                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        Internationalisation module for PHP
    ii  php7.2-json                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        JSON module for PHP
    ii  php7.2-mbstring                        7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        MBSTRING module for PHP
    ii  php7.2-mysql                           7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        MySQL module for PHP
    ii  php7.2-opcache                         7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        Zend OpCache module for PHP
    ii  php7.2-pspell                          7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        pspell module for PHP
    ii  php7.2-readline                        7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        readline module for PHP
    ii  php7.2-recode                          7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        recode module for PHP
    ii  php7.2-soap                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        SOAP module for PHP
    ii  php7.2-sqlite3                         7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        SQLite3 module for PHP
    ii  php7.2-tidy                            7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        tidy module for PHP
    ii  php7.2-xml                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    ii  php7.2-xmlrpc                          7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        XMLRPC-EPI module for PHP
    ii  php7.2-xsl                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              all          XSL module for PHP (dummy)
    ii  php7.2-zip                             7.2.34-22+ubuntu20.04.1+deb.sury.org+1                              amd64        Zip module for PHP
    ii  php7.3                                 7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.3-cgi                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php7.3-cli                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        command-line interpreter for the PHP scripting language
    ii  php7.3-common                          7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        documentation, examples and common module for PHP
    ii  php7.3-curl                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        CURL module for PHP
    ii  php7.3-fpm                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.3-gd                              7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        GD module for PHP
    ii  php7.3-imap                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        IMAP module for PHP
    ii  php7.3-intl                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        Internationalisation module for PHP
    ii  php7.3-json                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        JSON module for PHP
    ii  php7.3-mbstring                        7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        MBSTRING module for PHP
    ii  php7.3-mysql                           7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        MySQL module for PHP
    ii  php7.3-opcache                         7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        Zend OpCache module for PHP
    ii  php7.3-pspell                          7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        pspell module for PHP
    ii  php7.3-readline                        7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        readline module for PHP
    ii  php7.3-recode                          7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        recode module for PHP
    ii  php7.3-soap                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        SOAP module for PHP
    ii  php7.3-sqlite3                         7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        SQLite3 module for PHP
    ii  php7.3-tidy                            7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        tidy module for PHP
    ii  php7.3-xml                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    ii  php7.3-xmlrpc                          7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        XMLRPC-EPI module for PHP
    ii  php7.3-xsl                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               all          XSL module for PHP (dummy)
    ii  php7.3-zip                             7.3.28-2+ubuntu20.04.1+deb.sury.org+1                               amd64        Zip module for PHP
    ii  php7.4                                 7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               all          server-side, HTML-embedded scripting language (metapackage)
    ii  php7.4-apcu                            5.1.19+4.0.11-7+ubuntu20.04.1+deb.sury.org+1                        amd64        APC User Cache for PHP
    ii  php7.4-apcu-bc                         1.0.5-13+ubuntu20.04.1+deb.sury.org+1                               amd64        APCu Backwards Compatibility Module
    ii  php7.4-bz2                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        bzip2 module for PHP
    ii  php7.4-cgi                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php7.4-cli                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        command-line interpreter for the PHP scripting language
    ii  php7.4-common                          7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        documentation, examples and common module for PHP
    ii  php7.4-curl                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        CURL module for PHP
    ii  php7.4-fpm                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php7.4-gd                              7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        GD module for PHP
    ii  php7.4-imap                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        IMAP module for PHP
    ii  php7.4-intl                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        Internationalisation module for PHP
    ii  php7.4-json                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        JSON module for PHP
    ii  php7.4-mbstring                        7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        MBSTRING module for PHP
    ii  php7.4-mysql                           7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        MySQL module for PHP
    ii  php7.4-opcache                         7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        Zend OpCache module for PHP
    ii  php7.4-pspell                          7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        pspell module for PHP
    ii  php7.4-readline                        7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        readline module for PHP
    ii  php7.4-soap                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        SOAP module for PHP
    ii  php7.4-sqlite3                         7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        SQLite3 module for PHP
    ii  php7.4-tidy                            7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        tidy module for PHP
    ii  php7.4-xml                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        DOM, SimpleXML, XML, and XSL module for PHP
    ii  php7.4-xmlrpc                          7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        XMLRPC-EPI module for PHP
    ii  php7.4-xsl                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               all          XSL module for PHP (dummy)
    ii  php7.4-zip                             7.4.20-1+ubuntu20.04.1+deb.sury.org+1                               amd64        Zip module for PHP
     
  5. wbtech

    wbtech New Member

    Had to split it up a bit more so it would post...
    Code:
    ii  php8.0                                 8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                all          server-side, HTML-embedded scripting language (metapackage)
    ii  php8.0-apcu                            5.1.19+4.0.11-7+ubuntu20.04.1+deb.sury.org+1                        amd64        APC User Cache for PHP
    ii  php8.0-bz2                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        bzip2 module for PHP
    ii  php8.0-cgi                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        server-side, HTML-embedded scripting language (CGI binary)
    ii  php8.0-cli                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        command-line interpreter for the PHP scripting language
    ii  php8.0-common                          8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        documentation, examples and common module for PHP
    ii  php8.0-curl                            8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        CURL module for PHP
    ii  php8.0-fpm                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
    ii  php8.0-gd                              8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        GD module for PHP
    ii  php8.0-imagick                         3.4.4+php8.0+3.4.4-7+ubuntu20.04.1+deb.sury.org+1                   amd64        Provides a wrapper to the ImageMagick library
    ii  php8.0-imap                            8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        IMAP module for PHP
    ii  php8.0-intl                            8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        Internationalisation module for PHP
    ii  php8.0-mbstring                        8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        MBSTRING module for PHP
    ii  php8.0-memcache                        8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-1+ubuntu20.04.1+deb.sury.org+2 amd64        memcache extension module for PHP
    ii  php8.0-mysql                           8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        MySQL module for PHP
    ii  php8.0-opcache                         8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        Zend OpCache module for PHP
    ii  php8.0-pspell                          8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        pspell module for PHP
    ii  php8.0-readline                        8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        readline module for PHP
    ii  php8.0-soap                            8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        SOAP module for PHP
    ii  php8.0-sqlite3                         8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        SQLite3 module for PHP
    ii  php8.0-tidy                            8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        tidy module for PHP
    ii  php8.0-xml                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        DOM, SimpleXML, XML, and XSL module for PHP
    ii  php8.0-xsl                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                all          XSL module for PHP (dummy)
    ii  php8.0-zip                             8.0.7-1+ubuntu20.04.1+deb.sury.org+1                                amd64        Zip module for PHP
    ii  phpmyadmin                             4:4.9.5+dfsg1-2                                                     all          MySQL web administration tool
    ii  suphp-common                           0.7.2-0ubuntu1                                                      amd64        Common files for mod suphp
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Maybe remove that last backslash, that's all that seems off right off.
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Jesse Norell likes this.
  8. wbtech

    wbtech New Member

    @Jesse Norell. Thanks Jesse, I removed that last backslash. I'd left that there from adding additional lines to turn on more verbose error reporting. Unfortunately it didn't solve the issue.

    @Taleman I used the ubuntu auto installer:
    https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/

    I've got it working now, here's what I learnt! :)
    I messed up two things:
    1. I thought the server was clean, or clean enough, I'd installed apache2 on it but that was about it, and I knew that the installer would try and install that, skip it because it was already installed, and hopefully configure Apache the way ISPConfig3 wanted it.
    2. I'd downloaded ISPConfig3 previously and stuck it in a folder (/root/ispconfig). That happens to be a folder that the auto installer script checks to see if ISPConfig has been installed previously. If it finds it, it aborts the installation. Once, I'd run the script once, things got worse, I would / should have started over at this point but I had a large amount of data on the server which made that non-trivial.

    The main cause of the error was that the run group in /etc/apache2/envvars was wrong. My fault, I must have changed it. I set it back to:
    Code:
    export APACHE_RUN_USER=www-data
    export APACHE_RUN_GROUP=www-data
    and restarted Apache and ISPConfig's interface fired right up.

    In case I'm reading this in the future - I had to undo my config changes I made earlier:
    Code:
    a2dismod php7.4
    a2dismod mpm_prefork
    a2enmod mpm_event
    a2enmod fcgid
    systemctl restart apache2
    And another note to my future self, this is how I found out what was wrong:
    1. Set up a new virtual machine
    2. Install Ubuntu
    3. Install ISPConfig3 using the auto installer script (which worked perfectly on a clean system)
    4. Verify that the clean installed system works
    5. Copy the config files to the broken system
    6. Do a recursive diff
    7. Slap head repeatedly when you realise that you broke it yourself. :cool:
    Thanks for all your help.
     
    till and ahrasis like this.
  9. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Using auto-installer on non-clean system is always a problem. Glad that you resolve yours.
     
  10. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    I have installed ispconfig 3.1 to ubuntu 18.04. While installing it was working, however after I reboot the server, ispconfig panel is not opening. I get an error of Internal server error. I tried all possible solution mentioned in the forum, it's not working. Though I can open the website created while the admin was working. Phpmyadmin is also working. Please suggest.
     
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    https://www.howtoforge.com/community/threads/please-read-before-posting.58408/
    Why install old version of ISPConfig?
    On old version of Ubuntu? Latest Ubuntu supported by ISPConfig is 20.04.
    You did not say how you have installed ISPConfig.
    There is autoinstaller, it should work if started on minimal Ubuntu (or Debian) server install configured as instructed. https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/
     
    ahrasis likes this.
  12. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    I have installed using below guide:

    https://www.howtoforge.com/tutorial/ispconfig-3-automated-installation-on-ubuntu-1804/

    I am using AWS EC2 Ubuntu 18.04 AMI.

    After installation it was working fine, Issue started happening just after reboot. I can open website only admin panel for ispconfig is not opening.

     
  13. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    My ispconfig version is 3.2.5, just checked and ubuntu 18.04.05
     
  14. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    The tutorial you refer is not using official ISPConfig installer. Follow what @Taleman said above will be better. If everything else works, check if port 8080 is opened.
     
  15. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    Ok, i will reinstall and update here.
    Yes, port 8080 is open.
    Is there any chance PHP-FPM is not working on 8080? Where it is working on port 80 properly.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    php-fpm is not used on port 8080 on apache systems, port 8080 uses php-fcgi.
     
  17. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    Thanks for your reply.

    Is there a way I can open the admin panel page without reinstalling it? Reinstalling means I need to reupload all setup and data again.

    https://13.233.187.102:8080/ my linl
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the global apache error.log to find out why it is not working. And you can run an ispconfig update:

    ispconfig_update.sh --force

    and choose to reconfigure services during update, maybe it fixes the issue.
     
  19. Kuntal Chakraborty

    Kuntal Chakraborty New Member

    I tried, same issue. Does not help.

    In apache log in see the following:

    [Tue Jun 29 10:55:31.785727 2021] [fcgid:warn] [pid 27523] (104)Connection reset by peer: [client 122.163.122.197:11722] mod_fcgid: error reading data from FastCGI ser$
    [Tue Jun 29 10:55:31.785765 2021] [core:error] [pid 27523] [client 122.163.122.197:11722] End of script output before headers: index.php
     

Share This Page