ISPConfig page only works internally

Discussion in 'Installation/Configuration' started by djkoelkast, Dec 31, 2011.

  1. djkoelkast

    djkoelkast New Member

    The https://www.domain.tld:8080 page doesn't work for me, it's just doing nothing at all. The https://192.168.x.x:8080 however works just fine.
    I did open up the correct ports on the router, but could it be a iptables issue or something like that?
    Also my newly installed roundcube webmail works fine through http://192.168.x.x/webmail but doesn't on http://www.domain.tld/webmail (there it gives me a download called "webmail" which seems to be the index.php file itself, so it does not parse at all).

    Any clues on what is going on here and how I can solve this?
     
  2. djkoelkast

    djkoelkast New Member

    I solved the 1st issue, it was my own mistake on IP addresses.
    The webmail issue however still exists.
     
  3. cbj4074

    cbj4074 Member HowtoForge Supporter

  4. djkoelkast

    djkoelkast New Member

    I don't want it on webmail.domain.tld but on www.domain.tld/webmail, I do think there is a big difference.
    Also the webmail is working on my full IP too: http://212.xxx.xxx.xxx/webmail but on none of my domains

    This is /etc/apache2/sites-enabled/000-roundcube:

    Code:
    Alias /webmail /usr/share/roundcube
    
    <Directory /usr/share/roundcube>
      Options Indexes FollowSymLinks
      AllowOverride None
      DirectoryIndex index.php
      Order Allow,Deny
      Allow from all
    </Directory>
    <Directory /usr/share/roundcube/*>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/config>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/temp>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/logs>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/skins>
      Allow from all
    </Directory>
    <Directory /usr/share/roundcube/bin>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/SQL>
      Deny from all
    </Directory>
    <Directory /usr/share/roundcube/program>
      Allow from all
    </Directory>
    <Directory /usr/share/roundcube/plugins>
      Allow from all
    </Directory>
    
     
  5. cbj4074

    cbj4074 Member HowtoForge Supporter

    I discuss using this method in the cited thread, too.

    This indicates that Roundcube is configured to work only with your "default" site.

    Did you read the link to the "common pitfall" thread that I linked to in the aforementioned post? That thread is about SquirrelMail, but almost everything therein applies to Roundcube, too.

    http://www.howtoforge.com/forums/showthread.php?t=52042&page=4

    Once you've read through that, if you still have issues, let us know.
     
    Last edited: Jan 3, 2012
  6. djkoelkast

    djkoelkast New Member

    This fixed it, I edited the file /etc/apache2/sites-enabled/000-roundcube to:

    Code:
    Alias /webmail /usr/share/roundcube
    
    <Location /webmail>
    <IfModule suphp_module>
    suPHP_Engine Off
    AddHandler php5-script	.php
    </IfModule>
    php_admin_value open_basedir "/usr/share/roundcube"
    </Location>
    
    and then the rest there was.
    Now it works fine. It might be the "dirty" way, but I think it's better than disabling suPHP all together.
    Thanks for your help, I think more people come across this and now have a nice all in one topic solution.
     

Share This Page