ISPConfig + open_basedir restriction in effect

Discussion in 'Installation/Configuration' started by 010101, Apr 20, 2011.

  1. Julian

    Julian Member

    Can you please tell me how to make the fast-cgi to run the .html files?
    I put in htaccess:
    AddHandler php5-fastcgi .html

    but is not working!
    What code should I add in the options tab of the website in ispconfig to make it work?

    Thank you
     
  2. Julian

    Julian Member

    I fix it!

    AddHandler fcgid-script .html
    FCGIWrapper /var/www/php-fcgi-scripts/web32/.php-fcgi-starter .html
    AddHandler fcgid-script .htm
    FCGIWrapper /var/www/php-fcgi-scripts/web32/.php-fcgi-starter .htm
     
  3. Ark74

    Ark74 Member

    Hi!

    I would like to add info about this matter.
    I has this issue with a wordpress blog/site and for 3 nights i couldn't figure it out, so i think this could help anyone with this issue.

    The 3 main things to take into account when migrating;
    * Database
    * Files
    * .htaccess

    Make a recent backup of your db, use some tool like rsync to a high quality copy, once you have made those 2 let's check things out.

    Import the backup to the new database, then using a ssh session or by ftp, change the details on /path-to/your-site-or-blog/wp-config.php so they meet the new names and users for mysql (i used mysql).

    Then this is mayor, check inside the new database, maybe with phpmyadmin, look for the `wp_options` table and change the path to meet the new path in your new server.

    This was the issue that was holding me back from succeeding since everytime i look for the field to change i didn't found it, since phpmyadmin only show the first 30 options, i had to look for the next 30 so i could see and change the correct field. (I'm still learning about it).

    After that you might be all set, but if you see some weird behavior you might wanna check your .htaccess file for it to fully work.

    I hope that helps. See ya!
     
  4. pssadm

    pssadm New Member

    I know this is an old post, but for those experiencing an issue their logs filling up with OPENBASEDIR messages from WordPress. In my case, I moved a wordpress site to another server and the basedir messages started popping up.

    I've seen some users disable their cache altogether or even remove the basedir completely (not a good idea)....

    In my case, the answer was to go to the wp-config.php file and alter this...
    define( 'WPCACHEHOME', '/var/www/clients/client4/web4/web/wp-content/plugins/wp-super-cache/' ); //Added by WP-Cache Manager

    Good luck, I hope it helps!
    PSS Adm
     
    till likes this.

Share This Page