ISPConfig only works on LVM Partion?

Discussion in 'Installation/Configuration' started by alexsabau, Jun 30, 2014.

  1. alexsabau

    alexsabau New Member

    Hello. I recently bought an solus VPS, and cannot install centos with LVM, my current config looks like this:
    [[email protected] ~]# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/simfs 30G 1.2G 29G 4% /
    none 256M 4.0K 256M 1% /dev
    none 256M 0 256M 0% /dev/shm

    Does quota work on my current config? Thank you in advance.
     
    Last edited: Jun 30, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use lvm at all. Dont mix up lvm with normal linuy filesystem quota.

    If this virtualization is based on openvz, then the quota has to be enabled o the host server. you sgould talk with your provider then.
     
  3. alexsabau

    alexsabau New Member

    [[email protected] tmp]# quotacheck -avugm
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

    does this mean I cannot use ISPConfig at all ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You dont have to turn on quota on a virtual server with simfs, this has to be done by the host provider. Contact the hots provider and tell them to turn on Linux filesystem quota.

    ISPConfig works fine on servers with simfs. Beside that, quota is an optional feature anyway so you would be able to use ispconfig even on systems that dont support quota at all.
     
  5. alexsabau

    alexsabau New Member

    [[email protected] ~]# quotacheck -avugm
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.


    is this ok ?
    I had the tech guy enable quota on the host server.
     
  6. alexsabau

    alexsabau New Member

    [[email protected] ~]# cat /etc/fstab
    /dev/simfs / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 1 1
    none /dev/pts devpts rw,gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0


    should I make any changes here? thanks.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please revert the changes in /etc/fstab. Quota on your system is enabled on the host system only, there are no changes in the vm required.
     
  8. alexsabau

    alexsabau New Member

    [[email protected] ~]# quotacheck -avugm
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.


    I did but I still get this error. Is it ok ?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok, skip quotacheck and quotaon and proceed with the next step of the tutorial
     

Share This Page