ISPConfig on multiple servers - Certificate error

Discussion in 'Developers' Forum' started by martinfst, Jan 18, 2007.

  1. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I just installed ISPConfig on the second server and I hit the "Invalid certificate' syndrome.
    Reason: The site name used during certificate generation is pre-determined to be www (IIRC, can't scroll back so far in my ssh session window :( ). If this is true, shouldn't we change this to use the servername? Thus you can have multiple installations of ISPConfig on multiple servers in the same domain.

    The main server (tld if you want) domain is the same on both servers in my case.
    I'll go off now and regenerate the certs to fix this, but thought I'd just write this quick note. It will come back with each upgrade I'll do.....
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I just checked the sources, it looks like the ISPConfig installer is not setting a site name. The installer calls just:

    make certificate TYPE=custom
     
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Oke, you're using the default installer of Apache 1.3 I guess. I regenerated the certs (http://www.howtoforge.com/forums/showthread.php?t=1016) and I now have two servers happily running ISPConfig inside the same browser. Yes, I use FF2 on a Ubuntu WS for my client PC('s).

    I just need to try to remember to do this when an update of ISPConfig comes along. Hey guys, don't work to hard on an update then yeah ? :D
    I'll see if this can be modified in the install scripts whenever I have a spare minute.
     
  4. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    I backup my certs between updates and put garbage on the installer. It really should make cert names like ispconfig.crt and ispconfig.key

    next install, if it see them it doesn't regenerate them and reuse the old ones as part of the upgrade..nothing lost
     
  5. autoafrica

    autoafrica ISPConfig Developer ISPConfig Developer

    i need your help

    i know this post is kind of old.
    however, i need your help in settig up two servers.
    i have spent a week trying to connect my second computer to the first ispconfig with no success.
    based on what i have read ..you have already done it with success.
    i have choosen expert during the installation of the second server..
    i always get stuck at trying to connect to the first ispconfig database.
    could you tell me what to do exactly..
    i mean like the name of the master host
    datbase of the master host.
    master user name etc.
    please help help..i ma dying to do this .
    thanks in advance
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have not setup your mysql server correctly on the master. Try:

    mysql -h masterserver -u root -p

    from the slave. This must work, if not, then you have not added the hostname of the master and slave server to the hosts files on both systems or the mysql of the amster server is not configured for root logins from the slave server.
     

Share This Page