ISPconfig on debian ETCH

Discussion in 'Installation/Configuration' started by provell, Jan 19, 2007.

  1. provell

    provell New Member

    Hy Everyone,

    Due to hardware incompatibility with debian sarge, I am forced to use the etch version.
    The latest changelog of the ispconfig update showed support for debian/etch.
    So I was planning on following the perfect debian setup and then install ispconfig.

    As the perfect debian setup is bassed of sarge I have a couple of questions:
    Is there anyone who has tryed this before?:confused:
    Is there something I should do different during the perfect setup because it is etch and not sarge?

    Thanks in advance.:)

    Rgds Edo
     
  2. till

    till Super Moderator

    yes.

    The overall setup works. There are just some minor differences in e.g. the apache configuration file layout of the new debian version. I've not written down the exact differences, so I acnt give a complete list.
     
  3. provell

    provell New Member

    Thanks

    Thanks for the advice Till.
    I will give it a try and let you know how it turned out.

    At least now I know it has a change of succeeding.;)

    Rgds Edo
     
  4. provell

    provell New Member

    almost there????

    oooops....

    Whele the whole install whent prety whel dispite of some obvious changes.

    Only there was something not quite well with the mail system.
    I was suspecting something would go wrong with the saslauthd configuration because there were to many differences with the "perfect debian sarge setup" and unfortunatly it did.:(
    All of the rsa key validation went smoothly but still I can't connect to my pop3 server.

    I'm getting an error:
    There was a problem during connection/validation with the e-mailserver. You're user account is denied. Account: '10.0.0.230', Server: '10.0.0.230', Protocol: POP3, Reactie van server: '-ERR Unknown AUTHORIZATION state command', Poort: 110, Beveiligd(SSL): Nee, Serverfout: 0x800CCC90, Foutnummer: 0x800CCC91

    The http server is ok, the ftp server is ok!!!
    But connecting to the pop3 server keeps asking for a correct user??:confused:

    Anybody ... any ideas would be verry appreciated;) ;)

    Rgsd Edo
     
  5. till

    till Super Moderator

    SASL and pop3 are two different things. SASL is only for SMTP. Did you install courier as pop3 server?
     
  6. provell

    provell New Member

    follow up

    Hmmm SASL and POP3 are 2 different things yes..
    But in the perfect install they follow up each other to make the postfix install ready, so I thats why I thougt that.

    And no I have not installed courier as pop3 as far as I know.
    It comes up twice during the install but I did not installed it.
    Just to be sure I have enabled Maildir under Management -> Server -> Settings -> EMail in the ISPConfig web interface.
    Still the same error so no luck there.

    To test some more I installed webmail.
    Unfortunatly I first get the SSL YES/NO question and then page not found.

    As debian/etch is verry much related to Ubuntu6.10,and the postfix installation part looks more like the one of Echt.
    I will try to reconfigure/install postfix following the perfect ubuntu6.10 install.

    Probably have to reinstall ISP config afterward? right?;)

    Anyway thanks for the help so far!!:D
     
  7. till

    till Super Moderator

    Please install courier as described in the perfect debian setup, it will replace your currently installed pop3 daemon.
     
  8. provell

    provell New Member

    update

    Hy Till, thanks for you're quick respons.

    I have done the following:(From the ubuntu6.10 perfect setup)
    - apt-get install postfix libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail
    (this installed 2 extra packages as postfix was ofcourse already installed).
    - dpkg-reconfigure postfix

    Configured postfix like the setup sayd.
    Deleted the certificates and created new ones like the setup sayd.
    Configured postfix some more following the setup.
    /etc/postfix/mail.cf was correct like the example.
    Followed the setup to the end of the page.

    And after I saw you're reply I did.
    - apt-get install courier-authdaemon courier-base courier-imap courier-imap-ssl courier-pop courier-pop-ssl courier-ssl gamin libgamin0 libglib2.0-0

    Sorry, I read you're post to fast and the courier install was from the ubuntu6.10 setup and not the debian.
    I hope I did not screw up here.

    Anyway, the situation is still the same.
    Even while enabling maildir support in ispconfig.

    After a reboot I saw an error on the screen:
    Starting all courrier stuff OK
    * Not starting internet superserver: no services enabled.
    Starting postfix mail OK

    This can not be good.

    Any advice on getting this working is highly appreciated.
    Thansk in advance.

    Rgds Edo
     
  9. till

    till Super Moderator

    Reisnstalling the sasl stuff from the ubuntu howto was not a good idea, we nare now more far away from a solution then a few poats agi :( Its always a bad idea to mix dirrenet howtos, this will most likely result in a non working setup.

    1) Reconfigure the complete postfix stuff with the steps described in the debian setup.
    2) Install the courier packages as described in the debian setup.
    3) Send a email to a local mailbox from a webmail package on your server, e.g. uebimiau and post the lines that you get in the logfile.

    Maildir must be enabled.
     
  10. provell

    provell New Member

    back again

    I started the install of debian/ETCH and ispconfig all over again just to make sure.

    Because you said
    And now I have the same problem as I started with.
    And as you adviced
    1. Reconfiguring was done thrue the setup.
    2. Instaled it as the debian setup.
    3. ubable to, because postfix won't start and webmail either.

    This was the output of the installation:
    apt-get install courier-imap courier-imap-ssl courier-pop courier-pop-ssl <- NO
    websrv01:~/install_ispconfig# postconf -e 'home_mailbox = Maildir/'
    websrv01:~/install_ispconfig# postconf -e 'mailbox_command ='
    websrv01:~/install_ispconfig# /etc/init.d/postfix restart shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Stopping Postfix Mail Transport Agent: postfix.
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting Postfix Mail Transport Agent: postfixchdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    .



    This is what my /etc/postfix/main.cf looks like now:

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    # Uncomment the next line to generate "delayed mail" warnings #delay_warning_time = 4h
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for # information on enabling SSL in the smtp client.
    myhostname = websrv01.wwict.nl
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = websrv01.wwict.nl, localhost.wwict.nl, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions =permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    home_mailbox = Maildir/


    I would be verry happy if there still is a solution to this.
    Thanks in advance.

    Rgds Edo
     
  11. till

    till Super Moderator

    Thats all fine, nothing to worry about. you just executed the commands from within a non existing directory.
     
  12. provell

    provell New Member

    not all fine

    Hi till,

    Okee maybe the error's werent that big but I still don't have a working mail system on my ispconfig box.
    The normal pop or webmail are both not working.
    After the install of the courier/mail I now also have an error while starting up the server:
    * Not starting internet superserver: no services enabled.

    I also noticed that my spamassasin is not starting up due to errors.

    If you have any more tips on how to make this work on etch I'd be verry happy.

    Rgds Edo
     
  13. falko

    falko Super Moderator

    What's the output of
    Code:
    netstat -tap
    ?
     
  14. provell

    provell New Member

    closer

    Well it seems I forgot to set the "Maildir" option in ISPconfig settings.
    This did not help me the last time but this time it did.
    I now DO have a working pop server and can connect to it.

    Only when sending mail thrue SMTP, it again asks me for a password.:(
    The webmail unfortunatly is still not working.

    And as you asked here is the ouput of my "netstat -tap".

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 2064/mysqld
    tcp 0 0 *:81 *:* LISTEN 2535/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 2840/proftpd: (acce
    tcp 0 0 websrv01.wwict.n:domain *:* LISTEN 2817/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 2817/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 2817/named
    tcp 0 0 *:smtp *:* LISTEN 2787/master
    tcp6 0 0 *:imaps *:* LISTEN 2263/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 2282/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 2268/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 2251/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 2701/apache2
    tcp6 0 0 *:ssh *:* LISTEN 2382/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 2817/named
    tcp6 0 0 *:https *:* LISTEN 2701/apache2
    tcp6 0 148 websrv01.wwict.nl:ssh ::ffff:10.0.0.150:1216 ESTABLISHED10521/0

    My mail logs show an awfull lot of CHDIR's and messages that it cant find the directory.

    Rgds Edo
     
  15. provell

    provell New Member

    extra

    Some additional information:
    I have setup an extra test server.
    Started out with the perfect debian setup for sarge using the ETCH cd.

    When I got to the point of the install courier stuff, i did the install and booted afterwards.

    BAM!! the same errors show up as I have now.
    * not starting internet superserver: no services enabled.

    I think the courier stuff should not be applied in this way on an ETCH server.

    Any thoughts on this?

    Rgds Edo
     
  16. till

    till Super Moderator

    Thats no error. Its the correct notice that the suoerserver is not started which is correct and must be the case to run courier.

    The courier stuff must be applied and the message that you interpreted as error shows that you installed it correctly.

    This menas couries is working perfectly!

    This means that your SASL configuration is wrong.
     

Share This Page