ispconfig on a system with a desktop

Discussion in 'General' started by koekbr, Jul 8, 2007.

Thread Status:
Not open for further replies.
  1. mcsnakes

    mcsnakes New Member

    i have exact same problem did you fix it?? or can someone tell me how to fix this problem i have install fedora perfect but only if i install ispconfig i cannot use the taskbar or menu buttons :( need help!
     
    Last edited: Sep 12, 2007
  2. stahlo

    stahlo New Member

    I've also exactly the same problem.
    But what I find out is that a Gnome session over VNC works fine, only Gnome on the local console doesn't work.
     
  3. aranthorn

    aranthorn New Member

    You guys/gals need to read the entire thread, the fix is posted on page 2.
     
  4. stahlo

    stahlo New Member

    @aranthorn:
    I've already read the thread and found the fix on P2, but I don'd want to use KDE.
    And Maybe it is a hint for others to use VNC instead the local console if they want to use Gnome instead of KDE...

    Regards...
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You dont have to use kde, it is sufficeint to use the KDE login manager with the gnome desktop.
     
  6. stahlo

    stahlo New Member

    Ok, this is great!
    But the Fix on page 2 describes a solution to use complete KDE, am I right?

    Exist a manual or howto to replace Gnome login manager with KDE login manager?

    Thanks!
     
  7. curseddagger

    curseddagger New Member

    Same problem - Fedora 8

    Hey all, im glad to hear that i'm not the only one with this awefull situation. I have just installed fedora 8 several times with ispconfig and each time i get the same thing, system sits and waits before the login screen... logged in via putty and vnc and the system works fine, ctrl+alt+f1 brings me to the console and that works fine too... seems that its only after i install ispconfig... i have even tried interactive startup and said 'no' to starting ispconfig server, same problem!

    From what i have read i can just use the kde login manager with gnome desktop? will this cause any conflicts/problems? i would hate to not be able to use gnome!

    Cheers
    Curseddagger
     
  8. curseddagger

    curseddagger New Member

    Fixed It!

    well i have worked out a temporary fix for this problem many of us have been having. Until the bug with the gnome login manager and ispconfig is resolved here's what you can do:

    when you come to the part when your system stops loading the login manager hit ctrl+alt+F1 which will take you to a terminal, login as root.

    next we need to edit/create /etc/sysconfig/desktop so use vi, emacs or whatever your favourite console based editor is and edit/create the file
    example:
    emacs /etc/sysconfig/desktop

    you will need to edit/insert the following:

    DESKTOP="GNOME"
    DISPLAYMANAGER="KDE"

    save your changes, exit and reboot

    Basically this just uses the KDE login manager instead of the gnome one but still allows you to use GNOME as your desktop!

    Hope this helps anyone that gets stuck like i did

    p.s. this also works on fedora 8, i have tested it
     
  9. irstudio

    irstudio New Member

    OK
    so same problem here

    Basically the problem lies with GDM
    GDM is the default program in fedora that handles graphical logins
    (this is why you can log in remotely or from a virtual terminal ... you can also boot into runlevel 3 and login and startx manually)

    so what does ISPconfig do that GDM does not like??

    It doesn't look like it touches PAM or GDM itself directly.
    The only thing i can think of is that it may add the user "admispconfig" in a non-standard Fedora GDM incompatible way so that GDM hangs after that user is added.

    I have had trouble before with GDM and LDAP network logins where stupid GDM insisted on looking up user avatars over LDAP and of course they weren't there, so GDM would just sit there. Turning that off in this case did not help IIRC

    For now I switched to KDM,
    but the ISPconfig script should be fixed so that it does not interfere with GDM.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    If it was a problem with ISPConfig, then there would be the same problem on all distributions. But since it happens on Fedora only, I don't think it's an ISPConfig problem.
     
  11. Dan Thurman

    Dan Thurman New Member

    I have noticed that in Fedora 8, the /usr/share/gdm/default.conf, the default theme is: GraphicalThemes=FedoraInfinity. If you comment this out and uncomment #GraphicalThemes=circles/:happygnome, the ISPConfig should work using GDM and Gnome.

    But there is one thing I DO notice. Installing ISPConfig *does* affect Fedora's GDM. The question is, what exactly, is not known. I suspect it has something to do with changing the passwd, group, and other system files *somewhere* since Fedora uses getent in order for GDM to work with "FedoraInfinity" themes.

    I have tried to remove all traces of ISPConfig from my Fedora system and so far I have not been able to restore GDM's original state so that FedoraInfinity theme would work again.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

Thread Status:
Not open for further replies.

Share This Page