ispconfig on a system with a desktop

Discussion in 'General' started by koekbr, Jul 8, 2007.

Thread Status:
Not open for further replies.
  1. koekbr

    koekbr New Member

    Can ispconfig be installed on a system with a gnome desktop, the reason i ask is after installing ispconfig and rebooting the system, my system holts at gdmgreeter and does not display the graphical loginin screen.

    After searching on the net, i have found some users saying that ispconfig is for pure servers only. Is this correct, as all functions of isp config work perfectley, until you reboot the system and then you just cant login.

    Just a note, i followed the How To - The perfect server Fedora 7 exactly.
    ispconfig works perfectly.
    Now problems with system or hardware.
    Fedora 7 System
    Installed with desktop and server functionality.

    Can anyone help me.
    If i never turn the system of i can run ispconfig and server perfectly with no problems. But as soon as i reboot i just cant log back in. (ETSA Utilities doing electrical work in the house and had to turn power of for 1 hour otherwise i would of never turmed the system of)

    Please help.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig does not interfere with gnome. You can install it on a linux desktop as well as on a server, it makes no difference for ISPConfig or gnome.

    I do not think that your problem is caused by ISPConfig. But I'am not a expert for gdmgreeter to tell you what causes this software to hang.
     
  3. koekbr

    koekbr New Member

    All i know is that i follow the how to perfect server fedora 7, i update via yum, and i can use the gnome desktop as usual (after boot i get the login screen),Then after the whole how to, i reboot and all is still good. So i proceed to install ispconfig (this is all that is installed) then reboot and i cant get to login screen. (installed via /root/install_ispconfig/ ./setup)

    I tried ctrl + alt + f1 and used top and the PID it was stuck on was gdmgreeter so im asuming this is the error, it may not be. All i know is that everything is fine with my system until i install ispconfig (i dont install anything else) then i cannot log in. I really dont want to go back to leased licence of plesk, does anyone know what can be wrong.
     
    Last edited: Jul 8, 2007
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you follow the ISPConfig installation isnstructions http://www.ispconfig.org/manual_installation.htm and entered "n" in step 7 and 8 of the SSL certificate createion process? If not, it might be that your start scripts are waiting that you enter the SSL password before they proceed.

    If you encrypted your SSL certificate by not choosing "n" during setup, please create new certificates on the shell as described here:

    http://www.howtoforge.com/forums/showthread.php?t=121&highlight=firefox 8182
     
  5. koekbr

    koekbr New Member

    No i did not encrypt the ssl certificates. This is why i dont know what the error can be. It is really frustrating.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please disable the startup of the ISPConfig server by running:

    chkconfig --levels 235 ispconfig_server off

    and then reboot your server. Are you now able to login?
     
  7. danf.1979

    danf.1979 ISPConfig Developer ISPConfig Developer

    I have to servers. One for production, and one for developing. My dev server is my desktop computer with gnome and debian lenny, and it has ispconfig installed (version 2.2.10).

    I cannot update ispconfig though, lenny is not supported, but that is another problem. ISPConfig works fine here with gnome.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The update should work if you change the version number in /etc/debian_version to "4.0", update ISPConfig and restore the original version number after you updated ISPConfig.
     
  9. koekbr

    koekbr New Member

    I tried this but i get the error:
    Service ispconfig_server does not support chkconfig:(

    So i perform a interactive startup of my fedora 7 system and select NO when asked if i want the ispconfig_server to start. But i get the same problem can not get past loading gdmgreeter (just get a blue screen showing the mouse with the swirling blue lines showing it is trying to do something, i left it for 7 hours but it still did not get past it)


    The usual servcies that are running or started at startup are:
    microcode_ctl
    readahead_early
    kudzu
    cpuspeed
    ip6tables
    iptables
    isdn
    network
    loopback interface
    eth0
    auditd
    service restorecond
    syslog
    irqbalance
    mcstrans
    named
    rbcbind
    setroubleshoot
    nfslock
    mdmonitor
    rpcidmapd
    rpcgssd
    messagebus
    bluetooth
    httpd
    netfs
    pcscd
    hidd
    lm_sensors
    autofs
    qemu
    hplip
    cups
    sshd
    ntpd
    mysqld
    dovecot
    postfix
    nasd
    Console kit
    crond
    xfs
    anacron
    atd
    saslauthd
    readahead_later
    dhcdbd
    libvirtd
    yum-updatesd
    avahi-daemon
    haldaemon
    NetworkManager
    xend
    firstboot
    ispconfig_server
    local
    xenddomains
    smartd

    so i disable named, postfix, httpd, dovecot, proftpd, mysqld, ntpd and ispconfig_server. I get the same problem.:(

    I try to disable ispconfig_server by it self and i get the same problem.:(

    I am stumped. Do you think it would be beneficial for me to reinstall fedora 7 and try to install ispconfig via tty rather than the desktop. I know there is nothing wrong with my system as i had plesk 8.1 running fine for nearly a year. What strikes me odd is that the system works fine until you reboot. I cant seem to find the error. I have followed every guide to a tea.:confused:

    Please help.
    Why would ispconfig_server not support chkconfig

    Thanks Till.
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig supports chkconfig, but maybe not the version that you have installed. But this does not really matter as the ISPConfig installer has a different mechanism to enable ISPConfig. This has nothing to do with your original problem.

    If you want to disable ispconfig_server manually, just remove the symlinks to the ispconfig_server script in the directories /etc/rc0.d - rc6.d.
     
  11. koekbr

    koekbr New Member

    This worked. After removing ispconfig_server from automatic startup i am now able to see the login screen. Although the gnome desktop is not fully functional. All the desktop icons work, but none of the taskbar or menu buttons work. I changed the greeter from gdmgreeter to gdmlogin and booted with kde and it works fine, i can start and restart and work like normal.

    Why would the ispconfig system interfere with gnome so badly that even after disabling ispconfig_server it still has changed some of the settings and basically disbaled gnome. I would prefer to use gnome than kde as it is less resource hungry. But for now everything is working under kde anyway.

    Thanks till

    Brad
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That's the first time I hear of such a problem... :confused:
     
  13. red_marine

    red_marine New Member

    i have the exact same problem described in this thread, i performed a virtually full isntall of fedora core 7, and after installing ispconfig, the computer does not boot up anymore, it shows a black screen with a cursor that appears to be "busy"

    SSH putty works so i can access everything and the computer seems to be running as if nothing is wrong, however i cannot get the graphical interface working

    please, i hope someone can help out soon!
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  15. red_marine

    red_marine New Member

    it is the same problem, my cpu usage shows 70% cpu usage on gdmgreeter upon startup/freezing

    also my keys are not encrypted, when ispconfig asked if i would like to encrypt i said "no" to both times

    also the first time i installed i defaulted to the Yes both times, but reinstalled the fedora with no to both times and the problem is exactly the same

    this issue isn't related to the encryption of the keys at all, something funny is going on with gdmgreeter, tried to update gdm as well but it didn't help
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  17. zanard

    zanard New Member

    I had same problem, after restart ispconfig on fedora 7 login screen won't come up anymore. Command line working normally and process gdmgreeter takes full CPU...
    Is there somebody who can describe me what is purpose of gdmgreeter process.
     
  18. zanard

    zanard New Member

    Everything started when ispconfig install script connecting to mysql server to make necessary databases and initialize ispconfig panel, then /usr/libexec/fast-user-switch-applet takes all CPU usage (100%) and after restart login screen won't come up and another process gdmgreeter process takes CPU usage (100%). Killing these processes don't give any solutions, process will be started automatically again.

    I trying to switch KDE desktop instead of GNOME, maybe it helps...
     
  19. aranthorn

    aranthorn New Member

    Add me to the list of people with the same issue. I followed the fedora 7 perfect server to the letter, answered "no" to the encryptions and gnome doesn't load. So, I'm just hitting ctl-alt-f1 when it comes up to kill the gui and letting it run with the CLI on screen. I know you said you never heard of this before, but there appears to be a bug in 2.2.15 with gnome/fedora 7
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Its a bug in GDM that causes the gdm login manager to run at 100% CPU power when ISPConfig is installed. ISPConfig is running and starting fine on these fedora 7 gnome desktops.

    The only known solution is to replace the gnome desktop with a kde desktop:

    yum remove gdm
    yum groupinstall "KDE (K Desktop Environment)"

    vi /etc/sysconfig/desktop

    and add the following two lines to the file /etc/sysconfig/desktop

    DESKTOP="KDE"
    DISPLAYMANAGER="KDE"

    But as I posted already in this thread, we roceommend to not install a desktop enviroment at all.
     
Thread Status:
Not open for further replies.

Share This Page