ISPConfig not working after upgrade to Ubuntu 10.04

Discussion in 'Installation/Configuration' started by jkrell, May 2, 2010.

  1. jkrell

    jkrell New Member

    Hi. I upgraded from Ubuntu 9.10 to 10.04 this past week, and following the upgrade, ISPConfig appears to no longer be working. Is this a simple fix (for instance, maybe it is just not being started at boot) or is there something more sinister happening?

    I am troubled because I extensively updated one web site I run last month -- I do NOT want to lose all those changes!

    Please help if you can! I am happy to post files, logs, etc. -- I just do not know where to start!
     
  2. falko

    falko Super Moderator

    Please try this:
    Code:
    /etc/init.d/ispconfig_server restart
     
  3. jkrell

    jkrell New Member

    Thanks, Falko!

    Duh. That did it. Thanks, Falko!

    I actually entered:

    Code:
    /etc/init.d/ispconfig_server start
    It started OK and I verified the websites were up.

    Then, I entered:

    Code:
    update-rc.d ispconfig_server defaults
    Rebooted, and all is good.

    THANKS!
     
  4. kvess

    kvess New Member

    Same problem

    I have the same problem after upgrade. This did not work for me. When I ran the command I got this message.

    brian@server-1:~$ sudo /etc/init.d/ispconfig_server restart
    [sudo] password for brian:
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
    Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: libmysqlclient.so.15: cannot open shared object file: No such file or directory
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    /root/ispconfig/php/php: error while loading shared libraries: libmysqlclient.so.15: cannot open shared object file: No such file or directory
    ISPConfig system is now up and running!

    Websites are up but cant get to the ISPCONFIG page

    Thanks for any help!!
     
  5. falko

    falko Super Moderator

    Please install libmysqlclient16-dev...
    Code:
    aptitude install libmysqlclient16-dev
    ... and reinstall ISPConfig.
     
  6. kvess

    kvess New Member

    Error

    I did as instructed and I received this error at end and now nothing is working.

    Thanks

    Error

    ./setup2: line 1189: cd: /install_ispconfig/compile_aps/../..: No such file or directory
    brian@server-1:/install_ispconfig$
     
  7. kvess

    kvess New Member

    I also get this

    brian@server-1:~$ sudo /etc/init.d/ispconfig_server restart
    [sudo] password for brian:
    Shutting down ISPConfig system...
    /etc/init.d/ispconfig_server: line 66: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    ISPConfig system stopped!
    Starting ISPConfig system...
    /etc/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/init.d/ispconfig_server: line 48: /root/ispconfig/php/php: No such file or directory
    ISPConfig system is now up and running!
     
  8. falko

    falko Super Moderator

    What are the outputs of
    Code:
    ls -la /root/ispconfig/
    and
    Code:
    ls -la /home/admispconfig/
    ?
     
  9. kvess

    kvess New Member

    I reloaded my server then applied a backup.

    Thank you for all the help.
     
  10. hitri

    hitri HowtoForge Supporter

    Hi falko, I have t same problem.
    My outputs are:
    - ls -la /root/ispconfig/

    drwxr-xr-x 10 root root 4096 2010-05-25 22:24 .
    drwx------ 6 root root 4096 2010-05-25 22:34 ..
    -rwxr-xr-x 1 root root 44787 2009-11-07 23:20 cronolog
    -rwxr-xr-x 1 root root 9673 2009-11-07 23:20 cronosplit
    drwxr-xr-x 12 root root 4096 2009-11-07 23:01 httpd
    drwxr-xr-x 16 root root 4096 2009-11-07 23:20 isp
    drwxr-xr-x 7 root root 4096 2009-11-07 23:02 libmcrypt
    -rw-r--r-- 1 root root 8 2010-04-07 14:59 .old_path_httpd_root
    drwxr-xr-x 6 root root 4096 2009-11-07 22:58 openssl
    drwxr-xr-x 6 root root 4096 2010-01-22 17:36 php
    drwxr-xr-x 4 root root 4096 2009-11-08 11:00 scripts
    drwxr-xr-x 4 root root 4096 2009-11-07 23:20 standard_cgis
    drwxr-xr-x 2 root root 4096 2009-11-07 23:20 sv
    -rwx------ 1 root root 9389 2009-11-07 23:20 uninstall

    and for ls -la /home/admispconfig/

    drwxr-xr-x 4 admispconfig admispconfig 4096 2009-11-07 23:20 .
    drwxr-xr-x 5 root root 4096 2009-11-07 23:11 ..
    -rwxr-xr-x 1 admispconfig admispconfig 24 2009-11-07 23:20 .forward
    drwxr-xr-x 8 admispconfig admispconfig 4096 2010-04-07 14:59 ispconfig
    drwxr-xr-x 2 admispconfig admispconfig 4096 2010-05-18 04:01 mailstats
    -rwxr-xr-x 1 admispconfig admispconfig 176 2009-11-07 23:20 .procmailrc

    Thank you
     
  11. falko

    falko Super Moderator

    Looks ok. What's the output of
    Code:
    ps aux | grep wconf
    ?
    Does
    Code:
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    show any errors?
     
  12. hitri

    hitri HowtoForge Supporter

    ps aux | grep wconf

    root 4918 0.0 0.0 10732 1492 ? S May27 0:40 /bin/bash /root /ispconfig/sv/ispconfig_wconf
    root 28586 0.0 0.0 7620 924 pts/0 S+ 13:04 0:00 grep wconf



    Yes, I got this error:

    error while loading shared libraries: libmysqlclient.so.15: cannot open shared object file: No such file or directory
     
  13. falko

    falko Super Moderator

    Try this:
    Code:
    aptitude install libmysqlclient16-dev
    Then install ISPConfig again.
     
  14. hitri

    hitri HowtoForge Supporter

    Do I have to remove first the existing version or just reinstall it? Will I lose my sites and email accounts?
     
  15. falko

    falko Super Moderator

    No.

    Yes.

    No.
     
  16. hitri

    hitri HowtoForge Supporter

    I got this error, when installing Ispconfig (just end lines):

    gcc -c -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE _HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite `../apaci` htpasswd.c
    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/home/iztokm/install_ispconfig/compile_aps/apache_1.3.41/src/ support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/home/iztokm/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache




    Site is dead now?!
     
    Last edited: Jun 9, 2010
  17. falko

    falko Super Moderator

  18. hitri

    hitri HowtoForge Supporter

    It works. Falko, thank you very much. :)
     
  19. raymonvdm

    raymonvdm New Member

    I`ve had the same issue. I`m reinstalling ISPconfig2 now just see whats happening

    Code:
    
    
    <=== src/modules/ssl
    <=== src/modules
    gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` modules.c
    gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` buildmark.c
    gcc  -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/root/ispconfig/openssl/lib  -rdynamic \
    	      -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -lm -lcrypt  -lssl -lcrypto -ldl
    make[2]: Leaving directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41/src'
    make[1]: Leaving directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41'
    make[1]: Entering directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41'
    ===> src/support
    make[2]: Entering directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    gcc -c  -I../os/unix -I../include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite `../apaci` htpasswd.c
    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/home/beheer/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache
    
    
    

    After
    Take a look at chapter 22 on http://www.howtoforge.com/perfect-se...ispconfig-2-p7

    The problem seems fixed
     
    Last edited: Feb 6, 2011
  20. jang

    jang New Member

    I have the same problem, a broken ispconfig after trying to update to 2.2.40,, forgot to change the getline thing,

    But I don't seem to have anything in the tmp directory.

    home/admispconfig exists
    root/ispconfig is gone

    What to do now?
     

Share This Page