Ispconfig not working after Apache 2.4 update

Discussion in 'Installation/Configuration' started by guillego, May 12, 2016.

  1. guillego

    guillego New Member

    Hello, I just updated my server from Debian Wheezy to Debian Jessie.
    Everything seems to be working fine except all the ispconfig and the vhosts. I cannot access the control panel (I get ERR_CONNECTION_REFUSED when I go to mydomain.com:8080). If I go to my configured websites, they show a default Apache2 "It works!" website. I assume the whole Apache2 vhosts configuration is broken.

    I've been trying to debug it following Apache 2.2 to 2.4 migration guidelines and anything I've found on this site and searching on Google. No luck.
    I've run /usr/local/ispconfig/server/scripts/ispconfig_update.sh but it says I'm already in the latest version.

    This is my htf_report:
    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p9
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 5.6.20-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.20-0+deb8u1
    
    ##### PORT CHECK #####
    
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    
    ##### MAIL SERVER CHECK #####
    
    
    ##### RUNNING SERVER PROCESSES #####
    
    [INFO] I found the following web server(s):
            Apache 2 (PID 15913)
    [INFO] I found the following mail server(s):
            Postfix (PID 1810)
    [INFO] I found the following pop3 server(s):
            Dovecot (PID 630)
    [INFO] I found the following imap server(s):
            Unknown process (init) (PID 1)
    [INFO] I found the following ftp server(s):
            PureFTP (PID 1722)
    
    ##### LISTENING PORTS #####
    (only           ()
    Local           (Address)
    [anywhere]:465          (1810/master)
    [anywhere]:21           (1722/pure-ftpd)
    ***.***.***.***:53              (626/named)
    [localhost]:53          (626/named)
    [anywhere]:22           (620/sshd)
    [anywhere]:25           (1810/master)
    [localhost]:953         (626/named)
    [anywhere]:993          (1/init)
    [anywhere]:9091         (621/transmission-da)
    [anywhere]:995          (630/dovecot)
    [localhost]:10024               (1821/amavisd-new)
    [localhost]:10025               (1810/master)
    [anywhere]:53769                (621/transmission-da)
    [localhost]:3306                (1305/mysqld)
    [anywhere]:587          (1810/master)
    [localhost]:11211               (618/memcached)
    [anywhere]:110          (630/dovecot)
    [anywhere]:143          (1/init)
    *:*:*:*::*:465          (1810/master)
    *:*:*:*::*:21           (1722/pure-ftpd)
    *:*:*:*::*:53           (626/named)
    *:*:*:*::*:22           (620/sshd)
    *:*:*:*::*:25           (1810/master)
    *:*:*:*::*:953          (626/named)
    *:*:*:*::*:443          (15913/apache2)
    *:*:*:*::*:993          (1/init)
    *:*:*:*::*:995          (630/dovecot)
    *:*:*:*::*:10024                (1821/amavisd-new)
    *:*:*:*::*:53769                (621/transmission-da)
    *:*:*:*::*:587          (1810/master)
    [localhost]10           (630/dovecot)
    [localhost]43           (1/init)
    *:*:*:*::*:80           (15913/apache2)
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    fail2ban-pureftpd  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 21
    fail2ban-dovecot-pop3imap  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 110,995,143,993
    fail2ban-ssh  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 22
    DROP       all  --  ***.***.***.***      [anywhere]/0
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    
    And this is my 000-ispconfig.vhost file:
    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
    Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
              <FilesMatch "\.php$">
                      SetHandler fcgid-script
              </FilesMatch>
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
                Order allow,deny
          Allow from all
                  </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
      <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
          Options +FollowSymLinks
          AllowOverride None
                Order allow,deny
          Allow from all
                      php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      ErrorLog /var/log/apache2/error.log
      CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLProtocol All -SSLv2 -SSLv3
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
                Order Deny,Allow
        Deny from all
            </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
            Order Deny,Allow
        Deny from all
            </Directory>
    
    Any idea on how to fix it? I haven't found anything on Apache logs (I guess since it's not even listening on the 8080 port) Thank you very very much!
     
  2. Jesse Norell

    Jesse Norell Active Member

    download the ispconfig tarball, untar it and run update.php and answer yes to let it reconfigure services:
    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    You may still have to change .htaccess files or other apache config you would have manually added. See https://httpd.apache.org/docs/2.4/upgrading.html#run-time
     
    till likes this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Additionally to what Jesse psoted, please run Tools > Resync in ispconfig as final step to update the website vhosts as well.
     
  4. guillego

    guillego New Member

    Thank you so much Jesse and till! It's back up and running perfectly, thank you thank you! :) You can close the thread
     

Share This Page