ISPConfig not starting with following error

Discussion in 'Installation/Configuration' started by yohon, Feb 24, 2007.

  1. yohon

    yohon New Member

    Hi all,

    I run ISPConfig on a Fedora Core 6 box and noticed that my pop3 (dovecot) process was shutdown. I tried to bring it back on-line but it would not go. I went into management in ISPConfig and checked the database. It did have some errors so I clicked on repair database and everything went to ok. I thought that I would just reboot the server so I did. Everything started back up just fine but I can't get ISPConfig server to start. The following error is what I get, looks like something to do with ClamAV.

    [[email protected] postfix]# /etc/init.d/ispconfig_server restart
    /etc/init.d/ispconfig_server: line 66: syntax error near unexpected token ``ps ax | grep -iw '/home/admispconfig/ispconfig/tools/clamav/bin/freshclam' | grep -iv 'grep' | awk '{print $1}' | cut -f1 -d/ | tr '\n' ' '`'
    /etc/init.d/ispconfig_server: line 66: ` array5(`ps ax | grep -iw '/home/admispconfig/ispconfig/tools/clamav/bin/freshclam' | grep -iv 'grep' | awk '{print $1}' | cut -f1 -d/ | tr '\n' ' '`)'

    Any ideas on this? Everything else seems to be working fine - bind, apache, postfix, spamassassin, proftpd, etc. The other thing that does not work is roundcube webmail. I try to goto the correct URL but it does nothing. I am not sure if ClamAV and ISPconfig tie into this.

    I just can't get ispconfig to go. Here is a netstat -tap to show the processes.

    [[email protected] postfix]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdomain:2208 *:* LISTEN 2055/hpiod
    tcp 0 0 *:rpasswd *:* LISTEN 1864/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 2199/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1843/portmap
    tcp 0 0 firestorm.compassit.:domain *:* LISTEN 2875/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2875/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2072/cupsd
    tcp 0 0 *:smtp *:* LISTEN 2985/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2875/named
    tcp 0 0 localhost.localdomain:2207 *:* LISTEN 2060/python
    tcp 0 0 *:imaps *:* LISTEN 2805/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 2805/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 2805/dovecot
    tcp 0 0 *:imap *:* LISTEN 2805/dovecot
    tcp 0 0 *:http *:* LISTEN 2328/httpd
    tcp 0 0 *:ftp *:* LISTEN 2832/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 2086/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 2875/named
    tcp 0 0 *:https *:* LISTEN 2328/httpd

    Thanks in advance,

    Last edited: Feb 24, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks like your start script is corrupted. Please make sure that line 66 is like this:

    array=(`ps ax | grep -iw '/home/admispconfig/ispconfig/tools/clamav/bin/freshclam' | grep -iv 'grep' | awk '{print $1}' | cut -f1 -d/ | tr '\n' ' '`)
  3. yohon

    yohon New Member


    Thanks again. This has seemed to have done it. Now, I just have to figure out roundcube webmail, it is the only thing I have left that doesn't work at the moment. I am curious to know what may have caused this to begin with.

    Thanks again,


Share This Page