ISPConfig not starting, how to do it?

Discussion in 'Installation/Configuration' started by Einschtein, Dec 27, 2012.

  1. Einschtein

    Einschtein New Member


    I'm running Debian Squeeze and the latest ISPConfig. Now, I tried to upload something via FTP, it refused to upload it. So, I thought something was wrong with the CHMOD. (don't ask me how I thought of that)

    I rebooted the server and bam, ISPConfig is not working anymore. I tried the "/etc/init.d/ispconfig_server start|stop|restart", but it says that there is no such file or directory.

    Does anyone knows how to fix this? I don't want to loose all my files. The sites that are hosting by the ISPConfig are not working either, but the actual directories (/var/www/) are correct and the whole structure is also there.


    - einschtein
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3 is not a daemon, so it does not has to be started at all as it works as cronjob. The start script you refer to above is for a different software "ISPConfig 2", nothing thatyou read abut ispconfig 2 applies to ispconfig 3 except of the first part of the name.

    If you have a probem that ispconfig 3 is not applying changes to disk, take a look at the debug instructions.
  3. Einschtein

    Einschtein New Member

    Alright, but still. ISPConfig is not working, it's not responding to the website if I try to go to it. While Webmin, installed on the same server, does work. Also, the websites that ISPConfig hosts are also not working.
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    netstat -tap
    iptables -L
    ? Do you use apache or nginx?
  5. Einschtein

    Einschtein New Member

    Well, that is odd. (but great)

    It started working again after a bunch of reboots. Cheers though!

Share This Page