ISPConfig Not Saving Domain Options

Discussion in 'ISPConfig 3 Priority Support' started by yupthatguy, Jun 4, 2021.

  1. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Hey fellas,

    2 Questions:

    I am installing nextcloud and ran into an odd problem. Whenever, I attempt to "save" the php.ini options through the ispconfig gui, it simply scrolls back to the top of the page and the red, save in progress, indicator never appears.

    Also, when I load the options tab, I notice a split second pink error indicator flash by, then vanish, too quickly for me to read it.
    UPDATE: I managed to take a quick screenshot of the error message that vanishes
    [​IMG]

    It should also be note that options available on the options tab page change from screenshot above, to be:
    [​IMG]

    Investigating a bit... the error message doesn't make sense. My php version is
    Code:
    # php -v
    PHP 7.3.28-1+0~20210503.84+debian10~1.gbp6819da (cli) (built: May  3 2021 11:59:15) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.28, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.28-1+0~20210503.84+debian10~1.gbp6819da, Copyright (c) 1999-2018, by Zend Technologies
        with Xdebug v3.0.3, Copyright (c) 2002-2021, by Derick Rethans
    
    Also, on the primary domain settings I have:
    [​IMG]




    1.) How do I get the php.ini options to be save properly?

    2.) I am following this HTF tutorial for installing nextcloud with ISPConfig, are the opache php.ini options still relevant for ispconfig 3.2?

    opcache.enable=1
    opcache.enable_cli=1
    opcache.memory_consumption=128
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    opcache.revalidate_freq=1
    opcache.save_comments=1
    memory_limit = 512M
    upload_max_filesize = 500M
    post_max_size = 500M
    max_execution_time = 300

    Thanks
     
    Last edited: Jun 4, 2021
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not an error, as you can see when you read the text. It's information that when you are using php-fpm., which you are not using and that's why the message gots hidden, then you can't use certain settings for some older PHP versions.

    Which is exactly as it should be, you choose to use php-fcgi and what you see there are the options available for php-fcgi.

    The command you executed shows the PHP version of the php-cli of your server, this is not the PHP used by this website so nowhere related to anything you posted in your screenshots nor related to this website at all.

    Why do you think there is an error while all your screenshots show no error? If settings don't get saved, then double-check you clicked the right button (the save buttons) and check your browser that you are not using any ad or script blockers which might prevent javaScript from working properly. In case you are using any kind of security extensions on the server that block requests, then they might cause such an issue as well, in this case, you should check the logs of the security software you use to find out if it blocked the POST request.

    This is not related to ISPConfig, so ISPConfig versions do not matter for that. It's only related to what you have set in your global php.ini files. Today, opcache is most likely enabled by default, so no need to manually enable it a second time.
     
  3. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Thanks for the reply,

    Ok, so I went directly to the nextcloud.com site and read through their installation recommendations. They recommended php-fpm & 7.4 , so I switched versions under the domain settings accordingly.

    And the result is that you are correct (as usual)... the available options on tab options page changed according the process manager. (without flashing by)

    I thought/think there is an problem because when I enter the custom php.ini settings as follows:
    [​IMG]

    Then click save, it scrolls back to the top of screen, the red indicator does not appear.... and nothing else happens. If I navigate away from the options tab page, all of the settings are gone (unsaved)...

    [​IMG]

    My apologies, for the noobish bumblings, but its a little counterintuitive that the Custom php.ini settings don't seem to be saved... :confused:
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    They should be saved of course and they save fine here in current ISPConfig version, that's why I suggested that you check which plugins in your browser might prevent them from being saved or if you are using any kind of web application firewall that prevents them from being saved. You might also want to check the global apache error.log to see if an error is logged there while saving the php.ini settings.
     
  5. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Got it... will investigate... appreciate the feedback.
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    One last thing to check is the log for the built-in (to ispconfig) IDS, if it is set to blocking then some content can trip the rules and not save. I think you can see those messages under the monitor tab, but it's been a while and I don't remember exactly where
     
  7. yupthatguy

    yupthatguy Member HowtoForge Supporter

    @till was spot on... Rookie mistake, I didn't realize that I had to configure modsecurity rules on the empty directory, -before- I attempted the installation. Did my reading, things are working as expected. @Jesse Norell Thanks for tip though, I will add it to my troubleshooting list.
     
  8. yupthatguy

    yupthatguy Member HowtoForge Supporter

    Just a quick FYI,

    playing with modsec rules at the moment, turns out... opcache is not enabled by default. I enabled it via my php.ini file rather than ISPConfig, which means one less modsec rule exclusion.
     

Share This Page