ISPCONFIG not restarting apache

Discussion in 'Installation/Configuration' started by akaiser, Jan 5, 2007.

  1. akaiser

    akaiser New Member

    I've installed ISPCONFIG 2.2.9 and have some problems with the apache directives... but don't know if it's fault of the cms I use or some incorrect configuration...

    Anyway what I've noticed is that when I make changes in ISPCONFIG (for example creating a new site in ISPCONFIG) I have to restart Apache manually. I use Apache 1.3 and all ISPCONFIG configuration seems to be ok:
    Conf. Dir.: /etc/apache
    httpd.conf: /etc/apache/httpd.conf
    Document Root: /var/www
    but this seems to be incorrect:

    access Log: /var/log/httpd/ispconfig_access_log
    (not sure if this should be /var/log/apache/access.log)

    Last at ISPCONFIG log I have this line:
    05.01.2007 - 18:48:55 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 reload &> /dev/null
    Shouldn't this line be a /etc/init.d/apache reload (or restart)? Where can this be modified?
  2. falko

    falko Super Moderator ISPConfig Developer

    If you are sure you're using Apache 1.3 instead of Apache 2, then you must change some settings in the isp_server table in the ISPConfig MySQL database.
  3. akaiser

    akaiser New Member

    I changed in the mysql db "apache2" to "apache" and now the webserver seems to reload after doing changes in ISPCONFIG (of course I mean the apache server at port 80).

    Would this change in ISPCONFIG db affect the ISP Apache server at port 81?
  4. falko

    falko Super Moderator ISPConfig Developer

    No, not at all. :)

Share This Page