ISPConfig not creating website folders

Discussion in 'General' started by justinmccall, Mar 31, 2014.

  1. justinmccall

    justinmccall New Member

    Hi

    My ISPConfig isn't creating the web directories (/var/www/clientX/webY/) when I add a new site.

    I also note that in the settings for the site, it shows "[client_username]" instead of the actual name.

    [​IMG]

    What could be the problem?
     
    Last edited: Mar 31, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi
    It is normal. ISPConfig moulds the websites' directory automatically. Please create a test website & paste the output of
    There you can see the exact website directories.

    Br//
    Srijan
     
  3. justinmccall

    justinmccall New Member

    Thanks Srijan. But your last comment is my exact problem. The directories are not being created. Also, look at the directory names in the screenshot below, why are some under "[client_username]" instead of "clientX"? In this case the website I just added to ISPConfig is not even appearing in the directory list at all.

    [​IMG]
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please see here for instructions to debug your issue:

    http://www.howtoforge.com/forums/showthread.php?t=58408

    [client_username] is not a valid placeholder for open_basedir paths.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    the placeholder [client_username] that you inserted into the oaths is not a valid placeholder for paths in ispconfig, so you can nt use this placeholder. The client username may change and you can not use any placeholder that is changing in a website path.

    To ix your problem, restore the original path settings in ispconfig under System > server config > web.
     
  6. justinmccall

    justinmccall New Member

    Thanks, but I didn't change that at all. And according to System > Server Config > Web, it is setup correctly. See screenshot.

    [​IMG]

    It seems to me that ISPConfig is doing two things:

    1. It is not replacing [client_username] with the correct value
    2. It is not creating the directories at all for said website
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The website part on your setup is not the one of a fresh installed ispconfig, so someone must have altered it after the system installation. If you insert a invalid placeholder, then this placeholder is not replaced off course. Here are the correct paths:

    Website path: /var/www/clients/client[client_id]/web[website_id]
    Website symlinks: /var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/

    Please change the paths, then delete all websites that you added already and create them agaon.
     
  8. justinmccall

    justinmccall New Member

    Thanks, I did that. I added the new site with and according to Sites > Domain.Name.Com > Option, the path looks MUCH better "/var/www/clients/client21/web33/web:/var/www/clients/client21/web33/private:/var/www/clients/client21/web33/tmp:/var/www/domain.com/web:/srv/www/domain.com/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php". (Have removed real domain names for security on this forum)

    HOWEVER, those paths supposedly created by ISPConfig don't exist if I SSH into the box. Having said that, the Job Queue doesn't seem to be doing anything, is it a CRON issue?

    [​IMG]
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    I posted above a link how to debug issues like that.
     
  10. justinmccall

    justinmccall New Member

    Sorry about that, somehow I missed that. It seems that changing the paths worked. Thanks a ton, I'm all good to go! Appreciate all the help!
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Dont forget to enable the cronjob again, when you finished debugging :)
     

Share This Page