ISPconfig not allowing other server calls?

Discussion in 'Installation/Configuration' started by HackerJL, May 27, 2006.

  1. HackerJL

    HackerJL New Member

    ISPconfig is running very nice under suse 10.0 and a domain called tux.domain.com

    I then followed the guide to install the RPM mailman found here:
    http://mail.python.org/pipermail/mailman-users/2005-September/046441.html

    Everything went well. However once I go to http://tux.domain.com/mailman/ (with the last /) and I get a 403 error forbidden.

    Why is the question. I have configured ispconfig for the domain of tux.domain.com to execute cgi-bin and php..no difference.

    Is there something I can do here? Co-domain setup?

    Just a note...the link with the rpm for mailman...could be easily added to the perfect setup...very nicely.....help?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Try to put

    Code:
    ScriptAlias /mailman/ "/usr/lib/mailman/cgi-bin/"
    
    <Directory "/usr/lib/mailman/cgi-bin/">
            AllowOverride None
            Options ExecCGI
            Order allow,deny
            Allow from all
    </Directory>
    
    Alias /pipermail/ "/var/lib/mailman/archives/public/"
    <Directory "/var/lib/mailman/archives/public">
        AddDefaultCharset Off
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
    into the Apache Directives field in ISPConfig for the web site tux.domain.com.
     
  3. HackerJL

    HackerJL New Member

    going to http://tux.domain.com/mailman - still a 404. I have enabled cgi and php to run on this server. I restarted the service just to make sure.

    In the access log all I get is :
    "GET /mailman HTTP/1.1" 404 1181 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3"

    My error log: /var/log/apache2/error_log shows nothing.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have SuExec enabled, try to disable it.
     
  5. HackerJL

    HackerJL New Member

    oh...i tried with both the paragraph in the default-server.conf and without...thinking that duplicates wouldnt help...didnt help
     
  6. HackerJL

    HackerJL New Member

    Shouldnt have ever put it in...but where would i check that
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    In ISPConfig under management > server > settings on the web tab, there is a checkbox "Suexec".
     
  8. HackerJL

    HackerJL New Member

    Was never enabled.....
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you post your vhost configuration here?
     
  10. HackerJL

    HackerJL New Member

    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 24.72.141.95:80
    <VirtualHost 24.72.141.95:80>
      ServerName localhost
      ServerAdmin root@localhost
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.lainton.com:80
    ######################################
    #
    #
    <VirtualHost 24.72.141.95:80>
    ServerName www.lainton.com:80
    ServerAdmin webmaster@lainton.com
    DocumentRoot /var/www/web1/web
    ServerAlias lainton.com tux.lainton.com webmail.lainton.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^webmail\.lainton\.com [NC]
    RewriteRule   ^/(.*)$  http://www.lainton.com/webmail/$1  [R]
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: www.estevanwildlifefederation.com:80
    ######################################
    #
    #
    <VirtualHost 24.72.141.95:80>
    ServerName www.estevanwildlifefederation.com:80
    ServerAdmin webmaster@estevanwildlifefederation.com
    DocumentRoot /var/www/web2/web
    ServerAlias estevanwildlifefederation.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web2/log/error.log
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: tux.hjl.ca:80
    ######################################
    #
    #
    <VirtualHost 24.72.141.95:80>
    ScriptAlias /mailman/ '/usr/lib/mailman/cgi-bin/'
    <Directory '/usr/lib/mailman/cgi-bin/'>
            AllowOverride None
            Options ExecCGI
            Order allow,deny
            Allow from all
    </Directory>
    Alias /pipermail/ '/var/lib/mailman/archives/public/'
    <Directory '/var/lib/mailman/archives/public'>
        AddDefaultCharset Off
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
    ServerName tux.hjl.ca:80
    ServerAdmin webmaster@hjl.ca
    DocumentRoot /var/www/web4/web
    ServerAlias hjl.ca
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web4/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web4/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web4/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
     
  11. HackerJL

    HackerJL New Member

    Okay turns out just going to the tux.domain.com/mailman isnt gonna get your far in the first place. you need to go to /mailman/admin and then it all works...sorry for the newb
     

Share This Page