ispconfig + no-ip problem

Discussion in 'Installation/Configuration' started by Kuker, Aug 19, 2008.

  1. Kuker

    Kuker New Member

    hi i'm new to the forum, to linux and my english sucks so go easy on me

    i've setup a server with the ubuntu server hardy perfect server tutorial
    it's working and i've installed ispconfig

    on both configurations i used pubbli.no-ip.info as hostname and 192.168.200.100 as the server ip address
    (the server is behind a router)

    i also setup two accounts on no-ip, the pubbli.no-ip.info and pubbli2.no-ip.info
    both are redirecting to the server's internet ip address

    i've setup a site in ispconfig named smatte.com.br
    in ispconfig the site configured ip address it's also 192.168.200.100

    ok now when i try to access the site smatte.com.br from my internal network it's working ok
    but when i try to access from a external pc it's not working..

    when i ping pubbli.no-ip.info it gives me the correct ip address of my router
    but when i ping www.smatte.com.br also from a external pc the ip returned is 192.168.200.100

    can anyone help me with this?
    correct me if i'm wrong but apparently the nameserver it's working ok only its redirecting the browser to the wrong ip
    instead of redirecting to the external ip of my server its redirecting to the internal..

    how can i get this working with the dynamic ip? i don't have access to a permanent ip address so i need
    to get this working with the no-ip service

    thanks for any help
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server1:~# dig www.smatte.com.br
    
    ; <<>> DiG 9.3.4 <<>> www.smatte.com.br
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17946
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.smatte.com.br.             IN      A
    
    ;; AUTHORITY SECTION:
    com.br.                 900     IN      SOA     a.dns.br. hostmaster.registro.br. 2008082050 1800 900 604800 900
    
    ;; Query time: 132 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Wed Aug 20 14:46:31 2008
    ;; MSG SIZE  rcvd: 97
    
    server1:~#
    There's currently no DNS record for www.smatte.com.br.

    I'd set up a CNAME record for www.smatte.com.br pointing to pubbli.no-ip.info, so if pubbli.no-ip.info's IP changes, requests for www.smatte.com.br will automatically go to the new IP.
     
  3. Kuker

    Kuker New Member

    Hi falko thanks for the reply

    i'm sorry the domain www.smatte.com.br was just an example the real domain is www.smalt.com.br and the no-ip addresses are pubblicita.no-ip.info and pubblicita2.no-ip.info

    the cname record you said i have to setup it's on ipconfig? where can i setup it?
    thanks!
     
  4. falko

    falko Super Moderator ISPConfig Developer

    On the authoritative name server for that domain. As I see, you didn't define any name servers yet:

    Code:
    server1:~# dig ns smalt.com.br
    
    ; <<>> DiG 9.3.4 <<>> ns smalt.com.br
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 60899
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;smalt.com.br.                  IN      NS
    
    ;; Query time: 2674 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Thu Aug 21 20:03:11 2008
    ;; MSG SIZE  rcvd: 30
    
    server1:~#
    So you must go to your registrar's web interface and define some name servers first. This might give you the idea: http://www.howtoforge.com/ispconfig_dns_godaddy
     

Share This Page