ISPconfig (Nginx) can't connect phpMyadmin with https (404 error), but can with http

Discussion in 'Installation/Configuration' started by calbasi, Apr 11, 2014.

  1. calbasi

    calbasi New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats correct, as phpmyadmin runs on port 8081 on nginx. All you have to do is to set the correct phpmyadmin url under System > interface config in ispconfig.
     
  3. calbasi

    calbasi New Member

  4. dcurrey

    dcurrey Member

    Not sure if this is a correct fix be here is what I did to solve a similar issue.

    In CP goto server config. Then web at top. Open up section of Apps Vhost section.
    Changed the Apps-vhost Port to :
    Code:
     8081 ssl; ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt; ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key
    
    I set apps-vhost Domain to abc.myserver.com

    Not sure if that is correct way but it worked.
     
  5. calbasi

    calbasi New Member

    That's it!! Thanks a lot!!
     
  6. drewb0y

    drewb0y Member

    We should get this added to the Perfect Server how to, as it's not really going to work without it.


     
  7. S0ft

    S0ft Member HowtoForge Supporter

    Code:
    ssl on;
                    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
            ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt;
            ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key;
    
                    # redirect to https if accessed with http
                    error_page 497 https://$host:8081$request_uri;
    
    
     

    Attached Files:

Share This Page