ISPConfig needs DOM-XML php-extension/module for RoundCube

Discussion in 'General' started by Hans, Jun 11, 2008.

  1. JeGr

    JeGr Member

    Can you confirm, that this only happens with HTML mails? And can you further confirm, that this can be avoided (blank page phenomenom) by de-selecting the "show html mails" in your settings?
    Then, sir, we have the same problem but I'm still on 2.2.23 so I suppose(d) it has something to do with not having the DOM-XML module ready.
  2. fr3akdk

    fr3akdk New Member

    Yes I can confirm that Grey. When I remove the "show html" I can see the messages. But is there a workaround for this problem, so that the system displays html mails without error?.
  3. JeGr

    JeGr Member

    OK so we are on the same level and the same problem. I'll have a look into this as it seems strange to me, too.
  4. daveb

    daveb Member

    @ Grey,fr3akdk
    If you are using ispconfig 2.2.23 or older chances are that your php wasnt compiled with dom or xml support.
     @ 2.2.23
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL} [COLOR="Red"]--disable-libxml --disable-dom --disable-xml ${WITH_ZLIB_DIR} --disable-xmlreader --disable-xmlwriter --disable-simplexml[/COLOR] --without-pear || error "Could not configure PHP"
     @ 2.2.24
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL} [COLOR="SeaGreen"]${WITH_XML} ${WITH_ZLIB_DIR}[/COLOR] --without-pear || error "Could not configure PHP"
    You might also have to install libxml2-dev also, But a upgrade to at least 2.2.24 should fix your issues with DomDocument.php and roundcubemail.
  5. JeGr

    JeGr Member

    That was my thought, but as I understood fr3akdk, he is using 2.2.24 indeed.
  6. daveb

    daveb Member

    I also notice even in 2.2.24 if libxml2-dev is not installed it will revert to old behavior.
    which xml2-config
    if [ $? != 0 ]; then
      WITH_XML="--disable-libxml --disable-dom --disable-xml --disable-xmlreader --disable-xmlwriter --disable-simplexml"
    So possibly libxml2-dev is not installed?
  7. fr3akdk

    fr3akdk New Member

    I did a search on libxml2-dev and discovered that it wasn't installed. I tried installing it and restarting, but the problem is still there. Is there anything else i need to do?.
  8. daveb

    daveb Member

    I think you will have to run the install of ispconfig again "basicaly a upgrade" to reconfigure the php within ispconfig so it will support xml, dom.
  9. fr3akdk

    fr3akdk New Member

    Okay, to bad. I will try it out the next time i install ISPconfig, thx for your help.
  10. lewis_saint

    lewis_saint New Member

    I'm encountering the same problem, with ISPConfig 2.2.25. Did reinstalling ISPConfig ontop of an existing installation fix the issue?


  11. fr3akdk

    fr3akdk New Member

    Haven't tryed that Lewis, but I don't think it will help. I have tried making a new install with the same instructions as before and it is the same error i receive :-(

    I will report back if I have any success on this thread.
  12. daFritz84

    daFritz84 New Member


    is there already a solution to this problem? I basically have the same problem with ispconfig 2.2.27.

    I was also missing the libxml2-devel package. I tried to redeploy ispconfig like you do it for upgrading the system, but I had no luck.

    So long,
  13. id10t

    id10t Member

    In the same boat here...

    Fresh install of ISPConfig from earlier this week, roundcube 2.0 package from ispconfig website

    Turning off HTML mail does let it display whatever non-html mail message is there, which is kinda useless for my needs.

    Edit - here is how the PHP from ISPConfig is compiled...
    './configure' '--with-apxs=/root/ispconfig/httpd/bin/apxs' '--enable-track-vars' '--enable-sockets' '--enable-mbstring=all' '--with-config-file-path=/root/ispconfig/php' '--enable-ftp' '--prefix=/root/ispconfig/php' '--with-openssl=/root/ispconfig/openssl' '--with-mysql=/usr' '--disable-libxml' '--disable-dom' '--disable-xml' '--disable-xmlreader' '--disable-xmlwriter' '--disable-simplexml' '--without-pear' '--with-mcrypt=/root/ispconfig/libmcrypt'
    Last edited: Nov 19, 2008
  14. daFritz84

    daFritz84 New Member

    From what I learned, your ispconfig also compiled php with the wrong parameters.

    --disable-libxml --disable-dom --disable-xml ...
    I have a legacy system to maintain, so I cannot mess too much around. But maybe it is possible to modify the ispconfig package to force "dom document" support.

    I planned some closer examination of this problem for the coming weekend, since I need to setup some vm to debug this.
    But some more input is always welcome :D
  15. id10t

    id10t Member

    I think I am in the same boat. Yes, my ispconfig's php isn't compiled with the correct options...

    I wonder *why* though. Why is it that ISPConfig uses its own php engine instead of a system installed one. With the separation between apache and apache2 shouldnt' that be enough? Then it is a simple matter of apt-get installing the appropriate php module... Or is there something in ispconfig that is truly incompatible?

    What gets me is that I wouldn't have even installed the roundcube package (provided from ispconfig website) if there had been notes on it such as "mostly works, but does not support receiving html mail".

    Then again, I wonder why roundcube needs the extra stuff to display HTML mail. Should be as easy as dumping out some basic php/html (php to confirm person viewing has logged in as the user that owns said mail, the html is provided in the mail) to a temp file and redirecting browser in a new/popup window.
  16. daFritz84

    daFritz84 New Member

    You are absolutely right, but it doesn't help complaining about things we cannot change :rolleyes:. I will report back, if I'm able to provide some workaround.

    Maybe you have also some time to dig around in the ispconfig package.

    One hint, you need the "libxml2-devel" package for the dom-document support.;)
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    The information you refer to in this thread are outdated. The current ISPConfig version compiles PHP automatically with libxml2 support if you have the libxml devel package installed on your server. So to get libxml support in ispconfig php, install libxml2 dev package from your linux distribution, then download ispconfig 2.2.27 and run the setup script. ISPConfig will update your system then and compiles php with libxml2 support.
  18. daFritz84

    daFritz84 New Member

    Thanks for this information Till,
    but this doesn't work out for me. I exactly followed the steps you described, downloaded libxml2-devel package and try to update ispconfig to 2.2.27.

    Maybe the problem is/was that I had already 2.2.27 installed when trying those steps!?

    But I am not 100% sure if the problem is roundcube or ispconfig. Is there any method to verify dom document support?

    I tried this, which gives me no result...
    locate DOMDocument.php
  19. daFritz84

    daFritz84 New Member

    Just wanted to report back. I tried everything today to get php-DOM document support running. But no luck :(

    I saved a putty log of one of my ispconfig upgrade attempts to get this running (libxml2-devel is installed). Maybe someone can check this what's wrong...

    BTW I use CentOS 4.7
  20. make-fun

    make-fun Member

    Not working for me too

    Hi folks,

    same on my side — noway to get this to work for more then 6h now…
    1. Have "libxml2-devel" installed and is up to date
    2. Went from Version: 2.2.25 to Version: 2.2.27
    3. Went from RC1 to RC2
    4. Tryed mods on /root/install_ispconfig/compile_aps/compile
    ANYONE got this to work?
    How & where to you mod /root/install_ispconfig/compile_aps/compile
    What's this switch good for[line: 24]
    which xml2-config
    if [ $? != 0 ]; then
      WITH_XML="--disable-libxml --disable-dom --disable-xml --disable-xmlreader --disable-xmlwriter --disable-simplexml"
    I tryed to to change this line[24] and/or line[144]
    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all…
    Installed 2.2.27 7 times over and over — and ofcourse the certs broke 3times… so rebuilt them…

    In total frustration
    Last edited: Dec 1, 2008

Share This Page