ISPconfig: mysql error after installation

Discussion in 'Installation/Configuration' started by ewonde, Apr 9, 2007.

  1. ewonde

    ewonde New Member


    after following succesful the "Perfect Setup Debian Sarge 3.1" i tried to install ISPConfig. After the second time all worked out. But when logging in into ISPConfig, i get the following error (after! the loginscreen):

    Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    What to do???? I think it is something quit simple, but don't have the knowledge to figure out what...

    Thanks in advance, feedback is much appreciated, Erwin
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which mysql version do you have installed?
  3. ewonde

    ewonde New Member

    Find out that i ran the 4.x version of mysql client. After reinstalling mysql and mysql-client with libmysqlclient15-dev, restarting mysql and reinstalling ISPConfig everything worked out fine. For some reason this procedure first didn't worked, phpinfo kept giving back version 4.x for mysql-client, even when mysql-client was updated to 5.0.34 It seems that you have to reinstall mysql-server as well..?

    Shortly, everything is up and running :-D Thanks for your interest and help!

Share This Page