ispconfig multiserver setup - new nameserver

Discussion in 'Installation/Configuration' started by dodofox, Mar 2, 2016.

  1. dodofox

    dodofox New Member

    Hi Now I have this configuration:
    1 web server - 1 mail server - 1 db server - 3 nameserver.
    All work fine. Ns2 and ns3 are mirror of ns1.

    Now I need to add another ns. example ns4. I have installed debian, with ispconfig. In ispconfig panel --> System -->System Services I have edited ns4 with mirror of NS1. All ok. But now when I add from panel, for example, record A ccccc with ip 1.1.2.2 in one existing domain, in ns1 ns2 ns3 in directory /etc/bind i found pri.domain.com with for example::

    $TTL 86400
    @ IN SOA ns1.xxx.com. info.xxx.com. (
    2016030205 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    domain.com. 86400 A 1.2.3.4
    cccccc 86400 A 1.1.2.2
    ftp 86400 A 1.2.3.4
    imap 86400 A 1.2.3.4
    www 86400 A 1.2.3.4
    domain.com. 86400 MX 10 mail.domain.com.
    domain.com. 86400 NS ns1..xxx.com.
    domain.com. 86400 NS ns2..xxx.com.
    domain.com. 86400 NS ns3..xxx.com.
    domain.com. 86400 NS ns4..xxx.com.
    domain.com. 86400 TXT "v=spf1 a mx ptr -all"


    But in my ns4 I found this in pri.domain.com:

    $TTL 86400
    @ IN SOA ns1.xxx.com. info.xxx.com. (
    2016030206 ; serial, todays date + todays serial #
    28800 ; refresh, seconds
    7200 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    ;
    cccccc 86400 A 1.1.2.2
    domain.com
    . 86400 NS ns4.xxx.com.


    I found only the new record that I have inserted. NOT ALL... Why? This is a problem because when there is a query for example for ftp.domain.com my ns4 not reply correctly...

    thanks
     
    Last edited: Mar 2, 2016
  2. dodofox

    dodofox New Member

    Please help me...
     
  3. Jesse Norell

    Jesse Norell Active Member

    Try Tools > Resync > DNS Records
     
  4. webguyz

    webguyz Member HowtoForge Supporter

    The mirror only works with new records. For the old ones you need to do as Jesse recommended and use the Resync Tool for DNS to get all the old records.
     

Share This Page