ISPConfig multiserver setup mail server url not work

Discussion in 'Installation/Configuration' started by raziel00, Jan 27, 2021.

  1. raziel00

    raziel00 New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. raziel00

    raziel00 New Member

    Actually, I installed the ISPConfig server following this guide:
    https://www.howtoforge com/tutorial/perfect-server-ubuntu-20.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/
    I'm running apache2.
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Your example is unclear. If you go to server2.example.com/webmail, do you get this error? If so, create server2.example.com as web on that server.
     
  5. raziel00

    raziel00 New Member

    Hi,
    Like I said when i try to access roundcube with the url: https://isp2/roundcube i get ERR_SSL_PROTOCOL_ERROR
    But when i do https://isp2:8081/roundcube it works.

    I built 2 lab servers for testing did not have this kind of configuration when I followed the same guide. Now I have to add port 8081 to see it.

    I can't seem to find where the configuration has been done and how to change it.

    Thanks in advance.
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Is isp2 the control panel server name, not a vhost? Does the ispconfig interface with with https, only roundcube fails? What does 'apachectl -S' show?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    On apache systems, the default vhost has no ssl. So it's http://isp2/roundcube
    But this catually does not matter much, as you can easily change the config to where the mail client button points to, see my post above, so all you have to do is follow my instructions and change it to https://isp2:8081/roundcube
     
    Th0m likes this.
  8. raziel00

    raziel00 New Member

    To answer 2 questions here is the result for "apachectl -S"
    VirtualHost configuration:
    *:8081 isp2.local.ca (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:80 isp2.local.ca (/etc/apache2/sites-enabled/000-default.conf:1)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex mpm-accept: using_defaults
    Mutex fcgid-pipe: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex proxy: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/run/apache2/" mechanism=default
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: MODPERL2
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33

    I notice that there is no *:443

    So only http://isp2/roundcube

    How can we activate SSL for the webpage ?
    @till
    I couldn't find where to type in the address. Could you give me more details ?

    Thank guys.
     
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ISPConfig, click on System in the upper menu, then on Interface > main config in the left menu. On the mail table, you find the field "Webmail URL", there you enter the URL of your webmail client installation like "https://isp2:8081/roundcube".
     
    ahrasis likes this.
  11. raziel00

    raziel00 New Member

    Thanks Till and Th0m.
     

Share This Page