ispconfig multi server - adding rds as standalone mysql

Discussion in 'Installation/Configuration' started by craigfanman, Mar 28, 2017.

  1. craigfanman

    craigfanman New Member

    Hi. I've got an ispconfig multi server setup, theres 1 master server with just ispconfig (no websites), and about 5 servers that run apache/mysql and a few hundred sites each.
    I'd like to add a seperate RDS server just for mysql, am I able to integrate this with ispconfig? I've added servers to the setup in the past, but they always had ispconfig on it, this RDS server is mysql only, I cannot add ispconfig to it, so not sure how this would work?

    Any advice appreciated thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has to be installed on each server that is part of the ISPConfig server setup (server where you can add databases to from within ISPConfig).

    Why can't you add ISPConfig on that server? A ISPConfig database node runs just the ISPConfig server script as cronjob, so all you need to install is php, a few php modules and MySQL for ISPConfig (see database node of the multiserver setup tutorial).
     
  3. craigfanman

    craigfanman New Member

    thanks for the reply. I see I thought that was the case, the problem is this RDS server from AWS is just a standalone mysql server, you cant install anything on it it just runs RDS. so i can like manually site by site move a db there and change the db settings for the site. but i will be unable to create users on it etc through ispconfig....
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be posible to integrate an external mysql server in the way that you run a small vm for the ispconfig db node and then set this external mysql server in /usr/local/ispconfig/server/lib/mysql_clientdb.conf. You might have to make a fixed copy of the template mysql_clientdb.conf.master in /usr/local/ispconfig/server/conf-custom/install/ to make it update safe. I must say that I haven't tested this, so it might be that it does not work.
     

Share This Page