ISPconfig monitor

Discussion in 'Installation/Configuration' started by pititis, Mar 28, 2012.

  1. pititis

    pititis Member

    Hello,

    I'm using rescue in ispconfig but I found a problem with http monitoring.

    access.log
    Code:
    127.0.0.1 - - [28/Mar/2012:15:00:01 +0200] "GET / HTTP/1.1" 403 277 "-" "Mozilla/5.0 (ISPConfig monitor)"
    
    error.log
    Code:
    [Wed Mar 28 15:00:01 2012] [error] [client 127.0.0.1] client denied by server configuration: /htdocs
    
    Any idea please?
     
  2. till

    till Super Moderator

    Seems as if you redirect requests to 127.0.0.1 in your apache to a non existing directory called htdocs and this triggers the error. Please check that the default vhost directory of your apache server exists and that it contains some kind of index file like index.html
     
  3. pititis

    pititis Member

    Thank you Till,

    I think you are right, default vhost was disabled time ago.

    But /htdocs ? Default directory point to /var/www

    Code:
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
    
    more test, I did

    Code:
    root@server /etc/apache2 # grep -R htdocs *
    with no results.

    :confused:
     

Share This Page