ISPConfig manual abandoned?

Discussion in 'General' started by gbe, Mar 17, 2020.

Thread Status:
Not open for further replies.
  1. gbe

    gbe New Member HowtoForge Supporter

    Hey there,
    According to the ISPConfig Manual page, the manual was last updated 27 September 2016.
    But ISPConfig has had a lot of changes in the past 4 years.
    Maybe pull requests should also include documentation changes?
    Cheers
    Geoff.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The manual has not been abandoned, I just did not had the time to update it yet. Still more than 95% of ISPConfig functionality is covered in the current manual as it has been updated for the last Major ISPConfig version 3.1.0 and we currently have 3.1.15p3.
     
  3. Ole Vangen

    Ole Vangen Member

    Could maybe another format of the manual be a better solution that we can subscribe for? I downloaded the manual for some year ago and found it interesting, where it is now I dont know :D
    What I would love is a manual and a solution that had verified questions and solutions and/or tips how do to stuff.
    It is a lot of resources on net but some howtos that was like approved or controlled would be great.
    I naturally understand it might be impossible due to the different versions of OS and setups.

    Thanks for a great forum all!
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    With Howtoforge Subscription you can download the Manual when you want.
    There is ISPConfig FAQ, from the Documentation page: https://www.faqforge.com/linux/controlpanels/ispconfig3/
    My guess is a new manual is published when ISPConfig 3.2 comes out.
    Howtoforge Forums have questions and answers, how verified they are I do not know.
    There are lots of Tutorials on varying subjects on Howtoforge, they are useful. Old ones did not have publication date, but newer ones have.
     
  5. Digiiim

    Digiiim New Member HowtoForge Supporter

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Powerdns is not officially supported, so this very special topic won't be covered in the new version of the manual anyway.
     
  7. Kojo Unsui

    Kojo Unsui New Member

    Hi Till, thanks for the amazing work on ISPConfig and HowToForge tutorials. I've just installed 3.2 on a new Debian instance following https://www.howtoforge.com/perfect-server-debian-10-nginx-bind-dovecot-ispconfig-3.1/ , and it seems the documentation in the 3.1 manual is outdated about how ISPConfig handles certificates with Let's Encrypt and now acme.sh ?
    Any hope to see a new release of the manual ?( I bet I have the full collection ;-)
    Otherwise could you point me to some resources about that topic ? I can't get certificates issued. Which package should be installed ? in which directory are the certificates supposed to be written ?
    Thanks a lot
     
    Last edited: Mar 14, 2021
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    We are working on updating the documentation, but the current system is not very nice, so we are looking at different solutions. I can't make any promises on when you can expect a update.

    For help with the your certificate issue, please create a new thread with more info on your system.
     
  9. Kojo Unsui

    Kojo Unsui New Member

    Thanks for your quick reply, @Th0m !
    Meanwhile, I digged around and found all the stuff is being issued in root ~/.acme.sh/
    Just tell me please if the correct steps in the ISPConfig interface are :
    - create a site
    - edit it and fill in SSL tab, save with create certificate option
    - edit the site again and check SSL / Let's Encrypt checkboxes
    If the aboce steps are corret, It might then be an issue with my varnish configuration.
    I'll create a thread if I can't solve it this morning. Thanks again !
     
  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    No, you should not generate a certificate through the SSL tab. Remove that cert by disabling LE + going to the SSL tab and selecting "Delete certificate". Then save, open the web again, and enable LE.
     
    Kojo Unsui likes this.
Thread Status:
Not open for further replies.

Share This Page